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Custom Media Guide 
Content is King as they say (even Wikipedia says so), but adding some high quality intros, outros, themed 
callouts, and music can draw viewers into your video and keep them more engaged throughout.  

Camtasia Studio 7’s Library comes preloaded with media sets created from Digital Juice files – but, many 
people want to make their own so their videos better represent their company, personality, etc.  

In this Custom Media Guide, learn how to use freely available and common software and public domain files to 
create a unique Camtasia Studio Library media set.  

Also learn how to create a custom PowerPoint background that matches your media set, create a line art logo, 
add Snagit stamps as custom callouts, and more.  

 

Before You Begin 
The tutorials in this Media Guide are suitable for intermediate users of Camtasia Studio 7 and Snagit. Some 
working knowledge of recording with Recorder, working on the timeline, capturing with Snagit, using ribbon 
tabs, copying and pasting, saving files, and searching the Internet is helpful. 

 The estimated time to complete each of the tutorials is 15 minutes or less. 
 For more information on how to use Camtasia Studio or Snagit, see those application’s online help.  

 

Get the Necessary Tools and Files  
You’ll need the following to complete these tutorials: 

 Camtasia Studio 7 or later. Get the free trial here. 
 An image editor that supports transparency. The tutorials in this guide use Snagit 10. Get the free trial 

here. 
 A music visualization program such as Windows Media Player or iTunes.  

 iTunes comes preloaded with very nice visualizations. For Windows Media Player, you might need to 
download some visualizations that work well.  Get some free ones here. 

 A music clip at least 30 seconds in duration. A public domain audio file is used in this tutorial. Use your 
own audio file or search for “public domain MP3“ in your favorite search engine.  

 It is up to you to verify the music you use is in the public domain. If you use audio shareable under a 
Creative Commons license, always comply with the artist’s terms of use. 

 The Camtasia Studio output within Snagit. If you do not have the Camtasia Studio output installed, 
download and install from the TechSmith website. 

 

Want More Library Media Sets? 
We’ve created lots of Camtasia Library media sets in both Widescreen and Standard sizes. Each of these 
sets were created using techniques found in this Media Guide. Feel free to download, use, and share.  

 

http://en.wikipedia.org/wiki/Web_content#Content_is_king�
http://www.techsmith.com/camtasia/librarymedia.asp?cmp=dnl&NLC=d08�
http://www.digitaljuice.com/�
http://www.techsmith.com/download/camtasiatrial.asp�
http://www.techsmith.com/download/snagittrial.asp�
http://www.techsmith.com/download/snagittrial.asp�
http://www.microsoft.com/windows/windowsmedia/player/visualizations.aspx�
http://www.techsmith.com/snagit/accessories/camtasia.asp�
http://www.screencast.com/t/NzkwYWVkYT�
http://www.screencast.com/t/MTMyYTBiYWUt�
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Create a Camtasia Studio Library Media Set 
 The tutorials in this Media Set series are best worked on in the order they appear in this guide since each 
new tutorial builds on the work done in the previous tutorial.  

Here are the kinds of media assets commonly used to create great videos: 

 Intro and Outros: Live motion video introductions and conclusions that incorporate music, motion, and 
text for titles, credits, URLs, etc.  

 Title clip: Polished, coordinated graphics are a great way to break the video into sections.  
 Themed callouts: Similarly-themed or like-color callouts that match your presentation and add a level of 

professionalism.  
 Lower thirds: You’ve seen these all over on newscasts and elsewhere. They’re small, semi-transparent 

graphics in the lower part of the screen that contain the name of the person on screen, a title, locations, etc.   
 Music clips: A piece of music that’s synced with the video and uses fade in and fade out effects. 
 Sequence: A sequence is a fancy word for anytime there is more than one effect grouped together. For 

example, an intro might have music, video, and text. 
 

What You’ll Learn in This Tutorial Series 
This section of the guide is broken down into several tutorials that teach you how to create a complete media 
set for your Camtasia Studio 7 Library, including: 

 Intro / Outro Video with Audio Fades and Title Text 
 Still Image 
 Title Clip 
 Lower Third Callout 
 Coordinated Callouts 

See a demo of these elements in action 

 

 

Start Here! 
There are a couple things to do before you begin the Media Set tutorials.  

1. Import the Audio File into the Clip Bin 
Since you are creating your own video in this series, you only need to import an audio file. The audio you use 
should be at least 30 seconds long. 

 Use your own audio file or search for “public domain MP3” in your favorite search engine.  

1. In Camtasia Studio 7, click the Clip Bin tab to foreground it.  
2. Click the Import Media button. 
3. Browse and choose the audio file. Click Open. The audio file appears in the Clip Bin. 
 

2. Create a Media Folder in the Library 
Create a folder in the Library to keep all your new media assets organized. As you create the assets, you’ll add 
them to this folder.   

http://www.screencast.com/t/MmM1N2Q2OTA�
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1. Make a folder in the Library and give it the name of your media set.  

 
2. To create a folder, right-click in the blank space located between the bottom of the Library and the top of 

the Library tab.  
3. From the context menu, select New Folder and give your folder a name. 

 
 

To Add Your Media Assets to the Folder 

To add an asset to a folder, click and drag the asset on top of a folder and drop it there.  

 

Continue with Record the Visualizer. 
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Record the Visualizer 
Each of the assets created for your media set comes from a short video you record of a music visualization 
application.  

In this tutorial, learn how to record a minute or two of the music visualizer. From this one or two minute 
recording, you’ll create a final 30 second video used to create all the other media assets in the set. The final 30 
second video is called your “Source Clip”. 

Widescreen or Standard Format Media? 
Determine if you want to create a media set that is in widescreen or standard format. The tutorials in this guide 
record, edit, and create content in the widescreen, 800x450 format.  

If you prefer to use a standard format, record, edit, and create content using 800x600.  

Visualization Recording Design Considerations 
Here are a few design tips to keep in mind when recording the visualizer: 

 If possible, record the visualizer playing the music file used for the media set. This ensures the music and 
the video have similar beats, rhythm, visual / audio coordination, etc.  

 Slower, less up-tempo music creates a slower moving video while faster, more upbeat music creates a 
faster moving video.  

 Open the visualizer to the maximum size on your screen. 
 Record off-center – in a corner is best. This creates concentrated areas of live motion while providing 

empty space needed for text placement.  
 Turn off webcam and audio recording in Recorder. 
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Open the Music / Audio File in the Visualizer 
1. Open the music visualizer application and maximize it.  
2. In the visualizer, open the music / audio file you want to use to create the visualization.  
3. Make any adjustments to the visualizer settings to achieve the desired look.  
 

Record the Screen 
1. When the visualizer is set up, Open Camtasia Studio 7. 

2. Click the Record the Screen button . The Recorder opens.  
3. Click the Custom dropdown arrow. Choose 800x450 or 800x600 from the menu.  
4. Click and drag the recorder “compass” to position the recording rectangle over the area to be recorded. 

 
5. If the webcam is turned on, click the icon to turn it off.  

 
 
If audio is turned on, click the icon to turn it off.  

 
6. Click the Rec button to begin recording.  

 Record at least a minute so there is a good sample from which to create the Source Clip.  
 Record long enough to get a sample that has some light effects / empty / blank space. If you find the 

music or visualizer is too “busy” to allow for any empty space, you can choose another song or 
visualizer routine.  

 
7. When you are done recording, click the F10 key on the keyboard to stop recording. The recording Preview 

Window appears.  
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8.  Watch your video. If you don’t like your visualization, choose Delete and record again.  

When you are satisfied with your recording, chose Save and Edit . Give your video a name and 
click Save.  

9. The video appears in the Camtasia Clip Bin and on the Timeline. The Editing Dimensions dialog box also 
appears. From the dropdown menu, choose the Recording Dimensions option. Click OK. 

 
10. Close the Recorder and the visualization program. 

 
Congratulations! You learned how to record a music visualization program.  

 

Continue with Create the Source Clip. 
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Create the Source Clip 
All assets in your media set are created from a short section of your original recording called the Source Clip.  

This tutorial teaches you how to create the 30-45 second Source Clip.  

 For the Source Clip, choose a section of the original recording that has a large variety of visualizations 
going on. Look for a solid 30-45 seconds that has heavy, light, and no activity in it.  

 Your newly recorded video should be on the timeline and in the Clip Bin.  

 Your audio file should be in the Clip Bin. 

Select and Produce the Source Clip 
1. Drag your audio clip to the timeline. Play the audio and video together and drag the audio along the 

timeline to sync it up with the rhythm and beat of the video’s visualizations. Watch an example of how the 
video elements and audio rhythm can sync together. 

2. Play the video and stop the playhead when you reach an area that has little activity going on (this is called 
the blank area – use this when you create the outro video). If you do not have a blank area just find the 
end of a section of the video that you like.  

3. With the playhead stopped at the blank area location, grab the green portion of the playhead and drag it 
backward. The tip that appears shows the duration as you move the playhead. Make a selection that is 
between 30 and 45 seconds in duration. 

 
4. Stop the playhead on an area where you want the intro video to start. Release the playhead to make the 

selection.  
 
 
 
 
 
 
 
 

http://www.screencast.com/t/NjAzNTg4Mj�
http://www.screencast.com/t/NjAzNTg4Mj�
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5. Right-click the top of the selection and choose Produce Selection as from the menu. The Production 
Wizard appears.  

 
 

6. Choose Custom from the dropdown menu. Click Next.  

 
7. Make sure the MP4/FLV/SWF option is selected. At the bottom of the screen, check the Create MP3 file 

option. Click Next.  

 
8. Choose the No Controls option. Click Next. 
9. In the Video Options screen, click Next.  
10. In the Produce Video screen, give your video a name and choose a location to save it to. Click Next.  

 The name of your video should match the name of the folder you created in the Library. This helps 
keep your media set organized.  

11. The video begins rendering. When the video is done rendering the Production Results screen appears. 

Click the Open production folder button .  
 
The Open Folder dialog box appears that contains an MP4 and MP3 file. Do not close this dialog box.  

 

12. In the Production Results screen click the Finish button . The Production Wizard closes.  
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Clean Up the Timeline and Clip Bin 
13. Remove all files from the Clip Bin and all clips on the timeline.  

 Select each file in the Clip Bin with the mouse and press <Delete> on the keyboard.  
 Select each clip on the timeline with the mouse and press <Delete> on the keyboard.  

 Don’t worry! You aren’t deleting your original recording or audio file. This just removes them from the 
project since you won’t need them anymore.  

14. Drag the files from the Open Folder dialog box over to the Clip Bin and drop them there.  

 

 Alternatively, click the Import Media button and select the MP3 and MP4 files. They will import into the 
Clip Bin.  

The video and audio files appear in the Clip Bin. 

 

 At this time, only the new MP3 and MP4 files are in the Clip Bin and the timeline is empty.  

15. Right-click the audio file (MP3) in the Clip Bin and choose Add to Library. Drag it to the media folder you 
created in the Library and drop it there.  

 This saves a standalone copy of the audio file in the Library. 
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16. Drag the newly created MP4 file to the timeline and drop it there.  
17. Click the round, blue icon to unlock the video and audio tracks. When asked if you want to permanently 

unlink the audio and video, choose Yes.  

 
 

Add Source Clip to Library 
18. Right-click the video on the timeline and choose Add to Library from the menu. The video is added to the 

Library. 

 
19. Click once on the file in the Library. This allows you to name your video file. After the file is named, drag it 

to the media folder you created and drop it there.  

  
Congratulations! You learned how to create the Source Clip used to make the other assets in the media set.  

 

Continue with Intro / Outro Video with Audio Fades. 
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Intro / Outro Video with Audio Fades 
This tutorial teaches you how to select and save a 10-12 second section from the Source Clip to create a short 
intro or outro video that includes music fades.  

The 30-40 second Source Clip on the timeline is long enough to allow you to create different, but coordinating 
intro and outro videos - just choose different areas in the Source Clip. 

1. On the timeline, play the video to get a sense of the content in the clip. Then move your playhead to where 
you want to begin your intro or outro.  

 For your outro video, include the blank area – the location that includes light activity or no activity from 
the visualizer.  

 This tutorial teaches you to make one intro or outro video. You do not create both videos at the same 
time.  

2. Drag the red or green section of the playhead to make selection for your intro video. Use the tip that 
appears to see how long the clip is. It should be in the area of 10-12 seconds. Click Play in the Preview 
Window to view your selection. Repeat until you find an area you want to use as your intro / outro. 

3. Move the gray playhead to the end of the selection at the red out-point, click the Split tool on the toolbar.  

 
4. Move the gray playhead to the beginning of the selection at the green in-point. Click the Split tool on the 

toolbar. The splits created a video and audio section called a clip. 

 
5. Click the Audio tab. The audio track turns green. Click the Fade In and Fade Out buttons. 



Camtasia Studio 7           Create Custom Media 

www.techsmith.com  15 

6. Right-click the selected video clip on the timeline… 

 
,,, and choose Add to Library from the menu.  

 
The video / audio clip is added to the Library. 

7. Click once on the file in the Library. This allows you to name your intro file. Once the file is named, drag it 
to the designated Library folder and drop it there.  

 

Congratulations! You learned how to create an intro / outro video with audio fades.  

To preview the intro video, double-click it in the Library folder. 

 

Continue with Add Title Text to the Intro or Outro Video. 
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Add Title Text to the Intro or Outro Video 
This tutorial teaches you how to add title text to the intro / outro video clip created in the previous tutorial.  

1. Move the playhead to the center of the intro / outro section on the timeline.  

 
2. Click the Callouts tab. The callout options appear.  
3. Click the Open button to open the gallery view. Click the Text callout. 

 
4. The text callout is added to the timeline and the text options appear in the Callouts tab.  
5. In the Preview Window, move and size the callout as desired.  
6. In the text field, type “Enter Title Text Here”. 
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7. Change any of the attributes to your liking (font style, size, alignment, etc).  
8. Grab the end(s) of the callout on the timeline and drag them in either direction to adjust the duration of the 

callout to fit the size of the video clip.  

 
9. After all callout adjustments are made, double-click the video to move the playhead to the beginning of the 

clip. Grab the red out-point of the playhead and drag to select the entire intro / outro video clip.  
10. Right-click the selection on the timeline and choose Add to Library from the menu. The video / audio / 

callout sequence is added to the Library. 

 
11. Click once on the file in the Library. This allows you to name your intro file. Once the file is named, drag it 

to the designated Library folder and drop it there. 
 

Congratulations! You learned how to create an intro video with title text.  

To preview the intro video, double-click it in the Library folder. 

Continue with Create a Still Image. 
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Create a Still Image 
Use still images to create Title Clips or custom callouts. Still images can also be used to create a coordinating 
background for a PowerPoint presentation.  

1. Move the playhead to the frame to use as the still image. Look for a frame that has a place for text to be 
easily seen. 

 
2. Choose File > Produce special > Export frame as. 
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3. The Save frame as dialog box appears. Choose a location, give the file a name, and click Save.  
4. Click the Library tab. Click the Import Media button at the top of the screen.  
5. Browse and select this image. Click Open. 

 
6. Drag the still image to the designated Library folder and drop it there.  
 

Congratulations! You learned how to create a still image from a video frame.  

To preview the still image, double-click it in the Library folder. 

 

Add Text to a Still Image to Create a Title Clip 
Quickly create a Title Clip by adding a text callout to a still image.  

Use a Title Clips: 

 Before a clip on the timeline as a title or introduction 
 Between clips on the timeline as a chapter heading 
 At the end of the video to display credits or resources 

 

1. Drag the still image from the Library and drop it at the beginning of the timeline.  
2. Position the playhead in the middle of the title clip.  
3. Click the Callouts tab.  
4. Expand the gallery by clicking on the Open button. 

 
 

Choose the Text callout option . A callout is placed on the timeline at the position of the 
playhead.  

5. In the space provided, enter some sample text such as “Enter Title Text Here”. 
6. Select the text and adjust the font as desired. 
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7. Drag the text callout to the desired location within the Preview Window. If necessary, drag the handles to 
resize the callout so all of the text can be seen. 

 
8. On the timeline, drag the ends of the text callout to extend the duration to match the entire time of the title 

clip.  

 
9. Use the playhead to select the entire title clip and callout on the timeline. 

 
10. Right-click the selection on the timeline and choose Add to Library. Give this title clip a name. Drag to the 

media folder. 
 

Congratulations! You learned how to create a title clip from a video frame. 

To preview the title clip, double-click it in the Library folder. 

Continue with Lower Third Callout. 
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Lower Third Callout 
 This tutorial requires the use of Camtasia Studio, Snagit, and the Camtasia Studio output within Snagit. If 
you do not have the Camtasia Studio output installed, download and install it from the TechSmith 
website. 

A lower third is a semi transparent graphic placed in the lower area of the video. Lower thirds can contain 
graphical elements such as text, images or shading. Lower thirds are a useful way to introduce people, topics,  

 
When choosing a frame to use for your lower third callout, look for an area that has activity across the frame 
from left to right. 

 

http://www.techsmith.com/snagit/accessories/camtasia.asp�
http://www.techsmith.com/snagit/accessories/camtasia.asp�
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1. Move the playhead to the frame you want to use for the lower third callout.  
Choose File > Produce special > Export frame as… 

 
2. The Save frame as dialog box appears. Choose a location, give it a name, and click Save.  
3. Open the image in Snagit Editor. 

 
 
 
 
 



Camtasia Studio 7           Create Custom Media 

www.techsmith.com  23 

4. Drag the top and/or bottom canvas handles to adjust the height and create a section of the image that is 
about one quarter or one fifth of the original image. About 145 pixels high is a good size.  

 

 Do not drag the left or right canvas handles to adjust the width. This makes the callout too small. 

 

Here’s a look at a section that can be used for the lower third: 

 
5. Choose Image tab > Image Style group > Edges button > Fade Edge Options. 

The following settings work well. However, choose your own settings to get the desired look: 
 Apply to: Choose the top, right side, and bottom side buttons. 
 Effect size: Create an effect that leaves some unaffected area in the middle. This is where the text 

goes.  

 Click Add to Quick Styles. This adds the Lower Third settings to the Gallery so you can easily apply 
the effect to future callouts.  

When done, click OK.  
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6. Choose Send tab > click the Camtasia Studio icon.  

 
Return to Camtasia Studio. The image is in the Camtasia Studio Clip Bin.  

 
7. Position the playhead close to the middle of the timeline.  

 Positioning the playhead in this location allows enough room for the Fade in and Fade out durations 
to be included in the callout. 

8. Right-click the lower third image in the Clip Bin. From the menu, choose Add as callout. The image is 
added as a callout on the timeline at the position of the playhead.  

9. Double-click the callout on the timeline to open the Callouts tab.  
10. In the space provided, enter some sample text such as “Double-click to add text.” Select the text and 

adjust the font as desired. 
11. Drag the callout down to the bottom of the preview screen. 
12. Choose Effects button then click the Keep aspect ratio option to deselect it.  

 
13. Drag the top or bottom handles to decrease the height, if necessary. Reposition at the bottom of the 

screen. 
14. Right-click the callout on the timeline and choose Add to Library. Give this callout a name. Drag to the 

media folder. 
 

Congratulations! You learned how to create a lower third callout from a video frame. 

To preview the lower third, double-click it in the Library folder. 

 

Continue with Coordinated Callouts. 
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Coordinated Callouts 
Callouts are graphics that appear on top of a video to draw viewers’ attention to important objects or processes 
in a video. Creating callouts that use the same colors from the intro and Outro videos gives your video a more 
polished look.   

1. Move the playhead to the frame that has the colors you want to use.  
2. Click on the Callouts tab. The Callouts task page appears. 
3. Click the Add Callout button. 
4. Select a callout from the dropdown gallery. The callout appears in the Preview Window. 
5. Drag the callout to the middle of the Preview Window. 
6. Grab a callout’s handle to adjust the size.  
7. Change the Border and Fill color to match the colors in the video clip. 

 
8. Change other attributes and effects such as Shadow, Opacity and Style.  
9. When done, right-click the callout on the timeline and choose Add to Library. Give this callout a name. 

Drag to the media folder. 
 

Congratulations! You learned how to create a coordinated callout from a video frame. 

To preview the callout, double-click it in the Library folder. 

 

You have now completed each of the tutorials in the Create a Library Media Set tutorial series. 

See also: 

 Create Custom Callouts 
 Create a PowerPoint Template from a Still Image 
 Line Art Logo 
 Video Masking 
 Professional Newscast Appearance 
 Add QuickTime Movie Enhancements 
 3D Video Montage 
 Create a Camtasia Studio Library Media Set 
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Create Custom Callouts 
Custom Callouts can add interest and excitement to your video. There are many ways to make custom callouts. 
Here are three.  

 From Images You Already Have 
 From Snagit Captures 
 From Snagit Stamps 

 

From Images You Already Have 
Instantly create a callout from any image you import into the Clip Bin or Library.  

1. Position the playhead at the point of insertion on the timeline. 
2. Click the Clip Bin or Library tab.  
3. Click Import Media button at the top of the screen, 
4. Browse and select the desired image.  
5. Right-click the image in the Clip Bin / Library and choose Add as callout.  
6. Click the Library tab.  
7. Right-click the callout on the timeline. Choose Add to Library. Give this callout a name. Drag to the media 

folder. 
 

From Snagit Captures 
In this tutorial, learn how to create a custom graphic in Snagit and turn it into a Camtasia Studio callout. Once 
you learn the process, mix and match elements such as shapes, stamps, edge effects, and more to create the 
custom look you need. 

1. Take a capture of an interesting design or texture. The capture appears in Snagit Editor.  

 
1. Choose Draw tab > Drawing Tools group > Selection tool > Freehand Selection. 
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2. Draw a selection using the freehand tool.  

 
3. Press <CTRL + C> on the keyboard to copy the selection to the clipboard.  
4. Press <CTRL + N> to start a new canvas.  

 Make sure the background is set to Transparent. Choose Image tab > Canvas group > Canvas 
Color down arrow > Transparent. The transparent background displays as white and gray checks.  

 Need more space to draw on? Drag a handle of the canvas to make the canvas larger. 

 

5. Press <CTRL + P> to paste the shape on the new canvas.   
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6. Add any stamps, line or shape drawing, text, etc. to your image. Turn off the Shadow effect for each 
element added to your image. Choose Draw tab > Styles group > Effects down arrow > Shadow > No 
Shadow. 

 If you do not turn off the shadow effect, your image will not be completely transparent. 

 
 
In this example, a smiley stamp and some pen drawings are added.   

 
7. Right-click the canvas and choose Flatten All.  
8. Choose Image tab > Canvas group > Trim. 
9. Choose Send tab > click the Camtasia Studio icon.  

  
The image is sent to the Camtasia Studio Clip Bin.  

10. In Camtasia Studio, position the playhead on the timeline. Right-click the image in the Clip Bin. From the 
menu, choose Add as callout. The image is added as a callout on the timeline at the position of the 
playhead.  

 



Camtasia Studio 7           Create Custom Media 

www.techsmith.com  29 

11. Double-click the callout on the timeline to open the Callouts tab. Resize the callout and add any other 
embellishments such as text, border color, transparency, etc..  

 
12. When done, right-click the callout on the timeline and choose Add to Library. Give this callout a name. 

Drag to the media folder. 
 

Congratulations! You learned how to create a custom callout from a Snagit capture. Now, use this technique 
to create your own custom callouts to add your Camtasia Studio Library. 

To preview the callout, double-click it in the Library folder. 

Continue with: 

 From Snagit Captures 
 From Snagit Stamps 
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From Snagit Stamps 
Import your Snagit stamps into Camtasia’s Library and use them as callouts. Then use the Callout’s Fill and 
Border colors to change the look of the stamp. 

The TechSmith website has various stamps you can download for free. You can also perform a search for 
“Snagit stamps” in your favorite Internet search engine.  

In the following examples, a Snagit light bulb and number stamp are imported then customized to show some 
variations. (Find your stamps folder here: C:\Users\YOUR NAME\Documents\Snagit Stamps) 

 

 

http://www.techsmith.com/snagit/accessories.asp�
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Import a Snagit Stamp and Save as a Camtasia Callout 
1. In Camtasia Studio, click the Clip Bin tab. 
2. Click the Import Media button. Browse to the Snagit stamp folder: C:\Users\YOUR 

NAME\Documents\Snagit Stamps. 
3. Choose the stamp you want and click Open. The stamp appears in the Clip Bin. 
4. Right-click the stamp in the Clip Bin and choose Add as Callout.  
5. Double-click the callout on the timeline. The Callouts tab opens. 
6. Use the Fill and Border color options to change the look of the callout.  
7. If desired, add text.  

 
8. When finished, right-click the callout on the timeline and choose Add to Library.  
9. Give this callout a name.  
10. Drag to the media folder.  
 

Congratulations! You learned how to create a custom callout from a Snagit stamp. Now, use this technique to 
create your own custom callouts to add your Camtasia Studio Library. 

To preview the callout, double-click it in the Library folder. 
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Create a PowerPoint Template from a Still Image  
Use a still image from your video to create a PowerPoint template that coordinates with your Library media set.  

 To learn how to create a still image, see Create a Still Image. 

1. Open PowerPoint. Create a new, blank presentation.  
2. Choose View ribbon > Slide Master.  
3. In the slide navigation pane, click the first slide icon. The Slide Master ribbon is now in focus.  
4. Click the Background Styles down arrow in the Background group box. Choose the Format 

Background option. 

 
5. In the Format Background dialog box, click the Picture or texture fill option.  
6. From the options that appear, click the File button. The Insert Picture screen appears.  
7. Browse for and select the still image to be used for the PowerPoint background. Click Open.  
8. In the Format Background screen, click Close. The image is updated to the PowerPoint template. 
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9. Choose Microsoft Office button > Save As > Other Formats. In the Save As dialog box, give the 
template a name and select PowerPoint Template in the Save as type field. Click Save.   

 

Congratulations! You learned how to create a PowerPoint template with a still image from a video frame.  

 

To Use Your New Template 

1. Within PowerPoint, choose the Microsoft Office button  > New.  
2. In the New Presentation screen, click My Templates.  
3. Select your new template from the list.  
4. Click OK. 
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Line Art Logo 
You may have an image that you want to use as a logo in your video. This tutorial teaches you how to turn a 
color image into a black and white transparent logo.  

1. Open the image in Snagit Editor.  
2. Drag the canvas handles to trim the image. 

 
3. Make sure the background is set to Transparent. Choose Image tab > Canvas group > Canvas Color 

down arrow > Transparent.  
4. Choose Image tab > Modify group > Color Effects > Monochrome. 
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In the Monochrome dialog box, play with the slider to create an image that has high definition in the areas you 
want to keep and mostly erases the areas you don’t want to keep. When done, click the Close button. 

 
5. Use the Eraser tool on the Draw tab to clean up the edges and any miscellaneous spots on the canvas.  
6. Add other elements to the logo such as text, shapes, etc. If necessary, drag the canvas handles to make 

the canvas larger. 
 When adding text, turn off the Antialias effect.  

Choose Draw tab > Styles group > Effects down arrow > Antialias 
 For other elements, turn off the Shadow effect. 

Choose Draw tab > Styles group > Effects down arrow > Shadow > No Shadow.  
7. Choose Send tab > click the Camtasia Studio icon.  

  
Return to Camtasia Studio. The image is in the Camtasia Studio Clip Bin.  

8. Position the playhead on the timeline. Right-click the shape image in the Clip Bin. From the menu, choose 
Add as callout. The image is added as a callout on the timeline at the position of the playhead.  

  



Camtasia Studio 7           Create Custom Media 

www.techsmith.com  36 

Here is how the sample logo looks with the Callout’s Shadow option turned off.  

 

Here is the same logo that has been changed using the Callout’s Border color. 

 
9. When done with customizations, right-click the logo callout on the timeline and choose Add to Library. 

Give this logo a name. Drag to the media folder.  
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Video Masking 
Video masking allows you to take a still image from your video and create a frame or mask around the video. 
The mask has areas of transparency so portions of the video show through the mask. Use color and 
transparency options in Camtasia Studio to further customize the look. 

 
1. Create an image from a frame in your Source Clip. The frame should have an interesting portion of 

activity in it to create the mask’s pattern.  
 
In this still frame image, the selected area becomes the pattern for the mask. 
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2. Open the image in Snagit Editor. 

 Make sure the background is set to Transparent. Choose Image tab > Canvas group > Canvas 
Color down arrow > Transparent.  

3. Choose Draw tab > Drawing Tools group > Selection tool > Freehand Selection. 
4. Draw a close selection around the area to be used for the pattern. The interesting area created by some of 

the round circles is selected.  

 
5. When the selection is made, press <CTRL + C> on the keyboard to copy the selection to the clipboard.  
6. Press <CTRL + P> on the keyboard to paste the selection on the canvas.  
7. Grab and drag the pasted image to a location on edge of the canvas. Repeat until a border is created 

around the edges of the canvas. Don’t worry about the center of the canvas since it will be cut out. Here is 
how the image looks after the selection is pasted enough times to create a border. 
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8. When done with the pattern, right-click the canvas and choose Flatten All from the menu.  
9. Choose Draw tab > Drawing Tools group > Selection tool > Freehand Selection. Draw a selection 

around the edge of the canvas to outline the part that becomes the mask.  
Here is what our selection looks like. Make sure you leave enough room in the middle for the video to be 
seen.  

 
10. Press <Delete> on the keyboard. The middle section is removed. If you need to trim the border, repeat 

step 9 until you get the desired look.  

 
11. When done with trimming, Select Image tab > Modify group > Color Effects button > Monochrome. The 

Monochrome dialog box appears.  
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12. Experiment with the slider to find the setting that gives you the best results. The image should have some 
solid lines and white space for the image to show through when it is applied. When done, click Close. Here 
is how our image looks.  

 
13. Choose Send tab > click the Camtasia Studio icon.  

  
Return to Camtasia Studio. The image is in the Camtasia Studio Clip Bin.  

14. Position the playhead on the timeline. Right-click the shape image in the Clip Bin. From the menu, choose 
Add as callout. The image is added as a callout on the timeline at the position of the playhead.  
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15. If desired, use the Border color and Effects > Transparency option to change the look of the mask 
(which is now a callout on the timeline.) Here’s how our mask looks with a color applied to it and the video 
seen behind. 

 
16. When done customizing the mask, right-click the callout on the timeline and choose Add to Library.  
17. Give this callout a name. Drag to the media folder.  
 

Variations 
Apply more than one mask with different colors and varying transparency to create a 3-D effect.  
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Create several different masks and layer them on the video. 
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Professional Newscast Appearance 
Online and television newscasts often show an intro-style video playing in the background while the main video 
plays on top of it. See our example. 

To replicate this look: 

1. In Camtasia Studio, right-click the main video in the Clip Bin and choose Add to > Pip video. 

 
2. Drag the Source Clip to the Video 1 track.  
3. Add a Lower Third callout to the timeline.  
4. Double-click the callout on the timeline to edit it. Use the Preview Window to resize and position the callout 

on the Pip Video.   

 

http://www.screencast.com/t/NTE4NWRiOGEt�
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Add QuickTime Movie Enhancements 
The Production Wizard’s built-in QuickTime Movie enhancements and effects can instantly turn your video into 
a sepia or black and white film with scratches and dust. You can lighten, darken, and change the color of the 
video, add a posterize effect, sharpen or blur, apply a lens flare, and more.  

Click to see these some of these effects in action.  

Keep in mind when it comes to special effects like these, a little goes a long way. A numerical countdown intro 
with a black and white filter and some scratches and dust can give your video an interesting, retro feel. 
However, it might be distracting to the viewer if this effect were applied to the entire video.  

 

1. In Camtasia Studio, click the Produce and Share button. The Production Wizard appears.  
2. From the dropdown menu, choose Custom Production Settings. Click Next. 

 
3. Choose the MOV - QuickTime movie option. Click Next.  

 

4. Click the QuickTime Options button . The Movie Settings dialog box appears.  

 
 
 

http://www.screencast.com/t/MDAwMzg0NTAt�
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5. Click the Filters button. The Choose Video Filter dialog box appears.  

 
6. From the list Filters and Special Effects, choose the desired settings.  

 
7. When done, click OK.  
8. In the Movie Settings dialog box, click OK. 
9. Click Next. Continue on through the Production Wizard. 
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3D Video Montage 
If you have a visualizer that can create sky scenes with clouds, add an image as a callout to give your video 
the illusion of realism. Watch our video montage. You can also use this technique to create many other 
custom effects and illusions of depth.  

For this example, a capture of an interesting public domain image is used.  

 
1. Have your capture open in Snagit Editor.  
2. Drag the canvas handles to trim the image. 
3. Make sure the background is set to Transparent. Choose Image tab > Canvas group > Canvas Color 

down arrow > Transparent.  
4. In Snagit Editor, choose Draw tab > Drawing Tools group > Selection tool > Freehand Selection. 

 
5. Draw a selection around the areas you will not keep. Press <Delete> on the keyboard to delete the 

selections. In this example, the sky around the pagoda was removed. Some transparent areas in the trees 
are also created so sky will show through.  

6. Use the Eraser tool on the Draw tab to clean up the edges and miscellaneous spots on the canvas.  
The Eraser is used to make transparent areas for the pagoda’s windows and door. 

http://www.screencast.com/t/Y2ViZDE4Z�
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7. When done, choose Send tab > click the Camtasia Studio icon.  

  
Return to Camtasia Studio. The image is in the Camtasia Studio Clip Bin.  

8. Position the playhead on the timeline. Right-click the shape image in the Clip Bin. From the menu, choose 
Add as callout. The image is added as a callout on the timeline at the position of the playhead.  
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