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1 Introduction

This chapter introduces you to ImageScope and indicates where to find information on specific features.

Intended Use
For research use only. Not for use in diagnostic procedures.

ImageScope Features
Although the basic function of ImageScope is to allow you to view eSlides, ImageScope offers much more:

`` View eSlides from any workstation on the network, eliminating the delay of physically transporting glass slides 
from one department to another.

`` Share and discuss eSlides in real time in multiple remote locations by using eSlide conferencing.

`` View multiple eSlides concurrently.

`` Apply image adjustments in real time for contrast, brightness, and gamma.

`` Analyze entire eSlides or selected regions using algorithms.

`` Interface directly to a Aperio scanner through a network connection to view slides “live” and in different focal 
planes.

`` Rotate eSlide images and labels.

`` Use Aperio Integrated Color Management to view eSlides to ensure the eSlides are displayed in accurate color.

`` Use the Image Quality (IQ) feature to optimize viewing of an eSlide based on its stain.

`` Annotate eSlides, using these features:

yy Multiple drawing tools.

yy Ability to draw areas to be excluded from analysis.

yy Organize annotations by person or department by creating annotation layers.

yy Link annotations or images to create a viewing sequence.

yy Add text and descriptions to annotations.

yy Export and import annotations.

`` Interface to the Aperio ePathology ImageServer and eSlide Manager.

`` Instantly pan and zoom to any region of the slide. 
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`` Extract a region or selected regions of an eSlide to a file in a choice of formats.

Types of Files You Can View
You can use ImageScope to view:

`` ScanScope Virtual Slides – .SVS files created when the Aperio scanner scans glass microscope slides.

`` JPEG files – Both .JPG and .JP2 files.

`` TIFF and TIF files.

`` Aperio fluorescent images (Aperio Fused Image, .afi)

`` CWS files – Composite WebSlides1.

`` Hamamatsu NanoZoomer files – NDPI, .VMS, and .VMU files. Slide label images are not available for these 
images in eSlide Manager, ImageScope, Digital Slide Studio, and WebScope, as these images do not contain 
labels.

`` Zeiss Mirax files – .MRXS and SlideDat.ini files. (Note that Mirax images are composite images that consist of a 
group of .DAT files. Either the .MRXS or SlideDat.ini file can be opened to open the composite image.)

`` ScanScope image set, .sis file – The ImageScope image view is what you see when one or more eSlides are 
viewed in the ImageScope window. ImageScope enables you to save the image view as a ScanScope image set so 
that you can open all the slides at once in the future.

`` SCN files – Leica Biosystems SCN (SCN400 and Ariol versions) brightfield and fluorescent images.

For More Information
Here is where to locate information on ImageScope features.

How do I... Go to...

Install ImageScope?  “Chapter 2: Installing ImageScope” on page 12
View eSlides? “Chapter 3: Opening an eSlide” on page 14 

“Chapter 4: Viewing an eSlide” on page 22
Enable or disable clinical viewing mode? “Clinical Viewing Mode” on page 23 
Make annotations and link annotations or 
eSlides to make a viewing sequence?

“Chapter 10: Using the Annotations Window” on page 58

“Chapter 11: Linking Annotations and eSlides” on page 69
Use algorithms to analyze eSlides? “Chapter 9: Annotating eSlides” on page 55

“Chapter 14: Analyzing eSlides” on page 86
Use the algorithm tuning window to test 
algorithm parameters?

“Chapter 15: Registering Algorithm Macros on eSlide Manager” on page 
97

Create algorithm macros? “Chapter 15: Registering Algorithm Macros on eSlide Manager” on page 
97

Share slides with others in real time?  “Chapter 16: eSlide Conferencing” on page 106

1	 A Composite WebSlide, also known as a CWS slide, is a proprietary format created by Bacus Laboratories, Inc (“Bacus”). WebSlide® is a 
registered trademark of Bacus Laboratories Inc.
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How do I... Go to...

Display the image with a grid, scale axes, 
or a scalebar?

“Viewing Scalebar, Axes, and Grid” on page 30 

Adjust image color, brightness, contrast, 
and gamma?

“Chapter 6: Making Image Adjustments” on page 36 

“Chapter 7: Working with Fluorescence eSlides” on page 40 
Set and view image resolution? “Chapter 8: Image Resolution” on page 52 
Track movements through an eSlide? “Chapter 12: Tracking” on page 72

Rotate images and eSlide labels? “Chapter 5: Rotating Images and Slide Labels” on page 34 
Save image snapshots, email snapshots, 
and extract part of an eSlide?

“Chapter 13: Saving eSlides and Regions” on page 77

View a specimen in various focal planes 
directly on the scanner?

“Chapter 17: TelePath Live” on page 112

View live video from the scanner? “Chapter 17: TelePath Live” on page 112
Fine-tune performance? “Chapter 19: ImageScope Options” on page 125
Debug and troubleshoot? “Chapter 18: Utilities and Diagnostics” on page 121
Use keyboard shortcuts for ImageScope 
commands?

“Appendix A: Keyboard Quick Reference” on page 134

Use Aperio Integrated Color Management? ”Viewing with Color Management” on page 29

“Appendix B: Aperio Integrated Color Management” on page 136 
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2 Installing ImageScope

This chapter contains information on installing the client software for ImageScope.

This guide covers client installation of ImageScope. If you are installing other eSlide Manager 
components, see the Notes and News for the latest release or obtain the user guide for the application 
in question for instructions.

Before You Start
Before installing ImageScope, make sure your workstation satisfies these requirements:

`` Operating System – Windows 2000, Windows XP, or Windows 7

`` Memory – At least 256MB

`` Hard Disk – Must have at least 30MB of free hard disk space

`` CPU Speed – 450 MHz or faster

`` Video Card – Must support at least 24-bit color resolution

`` Monitor – Resolution should be at least 1024 X 768

Security Alerts

If during installation you see messages from Microsoft or third-party firewall, VPN, or virus software telling you that 
the installation has been blocked, you should consult your network administrator for help resolving these issues before 
continuing.

Administrative Privileges

Before running the installer, verify you are logged onto Windows as a user who has administrative privileges; otherwise, the 
installation will not be successful.
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 Installation
1.	 Double-click My Computer or open Windows Explorer and navigate to the ImageScope installer file. (This file may 

have been downloaded from the www.LeicaBiosystems.com/ePathology web site, may have been provided on CD, 
or may reside on your network; contact your network administrator for help if you have trouble finding it.)

If you are installing ImageScope on your DSR (Digital Slide Repository), use DSRInstall; if installing ImageScope on 
a user’s workstation, use ClientInstall.

2.	 Double-click the .exe file to start the installation wizard. 

3.	 Follow the instructions on your screen to accept the terms of the license agreement and install ImageScope.  

Modifying or Removing the ImageScope Software
At any time after ImageScope is installed, you can run the installer again to modify, repair, or remove the ImageScope 
software. If ImageScope is already installed, select from the following options on the installer window: 

`` Modify to change the ImageScope installation by adding or deleting components.

`` Repair to reinstall all the components previously installed. This is the option to use if you are upgrading a previous 
installation to new software.

`` Remove to uninstall the ImageScope software.

Starting ImageScope
To start ImageScope, click Start on the Windows taskbar, point to All Programs > ScanScope, and select ImageScope. 
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3 Opening an eSlide

This chapter contains information on opening and viewing eSlides in ImageScope.

Use ImageScope to view:

`` Local eSlides – images that reside on your workstation or your local network and are accessible using Microsoft 
file sharing (for example, by using Windows Explorer).

`` Remote eSlides – images that you open directly on an Aperio ePathology ImageServer or that you open using 
eSlide Manager.

Because Aperio ePathology eSlides are by design high resolution and information rich, for best results you should use a high 
quality monitor to view them. For details about monitor requirements, see the Aperio ePathology System Requirements. 

About User Permissions
ImageScope makes use of eSlide Manager security to enforce user permissions when viewing images.

The eSlide Manager administrator uses data groups and user roles to define what data you can see and what you can do 
when you see it. Data groups organize data such as eSlides into different groups that can be seen and used by different 
users. User roles define the commands you can use and the elements of an eSlide Manager page you can see.

What this means for ImageScope users is that when you open a remote image ImageScope may request that you log in so 
eSlide Manager can determine if you have the correct permissions to view the images you want to access. Type the same 
user name and password you use to log into eSlide Manager.

This also means that you may be restricted in what you can do with an eSlide. If, for example, you have read-only access 
to the data group that contains the eSlide you are viewing, you can use the ImageScope drawing tools to draw annotations 
but you won’t be able to save them. If you have questions about your user permissions, contact your eSlide Manager 
administrator for assistance.

Some of the features of the eSlide Manager security system you should know about are:

`` To keep user information secure, user credentials are encrypted and are never passed in clear text between the 
components of the eSlide Manager system.

`` User credentials can time out. If enough time elapses after you log in, you may be asked to log in again.

`` Data groups and user permissions are defined in eSlide Manager by the administrator.

Depending on how eSlide Manager is configured, you may be able to log in as Guest to see public images that do not 
require user authentication.
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Opening an eSlide on eSlide Manager 

Connection speeds may affect ImageScope performance when viewing remote images. For best 
viewing, we recommend a connection speed of 100 mbps or greater.

You can open a remote eSlide from eSlide Manager or you can open it from ImageScope. (For more details about using 
eSlide Manager, see the eSlide Manager Operator’s Guide.)

To open an eSlide from eSlide Manager:

1.	 With your web browser open to the eSlide Manager login page, log in to eSlide Manager.

2.	 Use the eSlide Manager List commands or search feature to find the eSlide you want to view.

3.	 Click the thumbnail image of the eSlide, or select the check box next to the eSlide and click View Images. 

The eSlide opens in ImageScope.

To open an eSlide Manager eSlide from ImageScope:

1.	 Go to the ImageScope File menu and select Access Remote Server to connect to eSlide Manager. 

2.	 Enter the name of the server on which eSlide Manager resides, and set the Port value to 82.

3.	 Click Connect.

4.	 When prompted, enter your eSlide Manager user name and password. eSlide Manager displays a page of eSlides.
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5.	  Select either the List or Thumbnail view from the drop-down list at the upper right.

6.	 Click the ImageScope link below the image.

Opening an eSlide on Your Workstation or LAN
To open an eSlide that resides on your workstation or local area network:

1.	 Start ImageScope by clicking Start, pointing to All Programs > ScanScope, and then selecting ImageScope.

2.	 Go to the File menu and select Open Image (or click  on the ImageScope toolbar).

3.	 On the Open Image window, navigate to the location that contains the image you want to view.

4.	 Click the name of the eSlide you want to open and click Open.

You may need to change the file type in the Open Image window to see the type of image you want to view. For example, to 
view a CWS image, click the file type drop-down list and select Composite WebSlides (*/SlideScan.ini).

Local Image Support

If you open a local image instead of an image in eSlide Manager, Smart sync, Tracking, and IQ are not supported for that 
image.

Opening a Recently Viewed Local eSlide

ImageScope displays a list of the last few eSlides that were viewed on the File menu. To open one of these images, go to 
the File menu and click one of the eSlides listed at the bottom of the menu.
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Opening and Viewing Multiple eSlides
You can open multiple eSlides within ImageScope. To open multiple eSlides in eSlide Manager:

1.	 Log into eSlide Manager.

2.	 Locate the eSlides you want to use by using the eSlide Manager List command or search feature. 

3.	 Select the check boxes next to the eSlides you want to view, and click View Images:

The eSlides open in ImageScope:

You can view all the slides at once or view them separately by selecting Tile Vertical, Tile Horizontal, or 
Cascade from the Window menu.
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You can move between the opened images by clicking on an image in the filmstrip. 

If the ImageScope filmstrip is not visible, go to the View menu and select Filmstrip. 

Managing eSlide Windows

To maximize, minimize/restore, or close the individual eSlide windows within the ImageScope main window, click the slide 
icon on the image menu bar and select an action to perform.

Keep Open Option

When you select one or more multiple images in eSlide Manager (by clicking the thumbnail or selecting multiple images and 
using the View Images command), any images already open in ImageScope are closed before displaying the new ones. 

To do this: Do this:

Keep an image open in ImageScope 
when you open another image from 
eSlide Manager.

Select the image in ImageScope, and then go to the Image menu and select 
Keep Open.

Do this for each image you want to keep open.

Close an image Select the image, go to the ImageScope File menu and select Close Image.
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Viewing eSlide Information
To view information, such as the image size, location, and compression ratio, about the currently selected eSlide, go to the 
Image menu and select Information or click  on the toolbar. The Image Information window appears.

The table below describes the type of information that appears in each tab.

Go to this tab: To view this information:

Information Provides detailed data regarding the eSlide, including the magnification, 
image ID, and description. The ICC profile is provided if one is being used. (See 
“Appendix B: Aperio Integrated Color Management” on page 136  for 
information on ICC profiles and color management.)

If this eSlide was scanned on an Aperio scanner, the time zone of the scan 
location and time of the scan appear. The Information tab is always shown. 
The other tabs only appear if those elements are associated with the eSlide. 
For example, if there is no label image for this eSlide, you do not see the Label 
Image tab.

For an Aperio Fused Image (AFI), the Information window contains information 
on the separate channel images that comprise the AFI image.

Thumbnail A thumbnail image of this eSlide (the area of the glass slide that was scanned).

Label image The eSlide label.

Macro image A macro image of the entire slide.
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Status Bar

Information on the selected eSlide can also be seen in the status bar at the bottom of the ImageScope window. For example:

The sample status bar above shows the following information:

`` 73091 x 62821 = 12.8GB, file = 575MB – This means that the entire eSlide is 73,091 by 62,821 pixels in size. The 
eSlide’s raw data is 12.8 gigabytes in size and the compressed size of the eSlide file is 575 megabytes.

`` 0, -12950 : 73091 x 62821 – The first two numbers indicate the pixel position of the top, left corner of the display. 
The second numbers indicate which part of the image is being viewed.

`` 1815, 37033 – This indicates the current pixel position of your cursor.

`` Prefetching/progressive rendering – Indicates which performance options are in effect. For information on 
performance options such as prefetching, interpolating, and progressive rendering, see “Performance Options” on 
page 130.

`` PAN – This shows which navigation or annotation tool is selected. In this case, panning is selected.

You can turn the status bar off by going to the View menu and selecting Status Bar. This command reverses the current 
state of the status bar display: if the status bar is showing, this command hides it; if it is hidden, this command shows it.

Saving and Opening an Image View
If you have a group of eSlides that you want to view together, you can save them as an Image View. An Image View is the 
entire set of slide images that are open at one time in ImageScope.  

To do this: Do this:

Save an Image View 1.	 Go to the File menu and select Save Image View(s). The Save Image 
View(s) window appears. 

The file type for an Image View is ScanScope Image Sets (.sis).

2.	 Type the name you want to use for the file and click Save.

Opening an Image View 1.	 Go to the File menu and select Open Image. Locate the .sis file you 
saved on your network. You need to select .sis from the Files of type 
drop-down list to see the file.

2.	 Select the .sis file to open and click Open. ImageScope opens the .sis 
file with all eSlides in that image view open and in their former pan 
and zoom configuration.



ImageScope User’s Guide, Revision O © Leica Biosystems Imaging, Inc. 2014 21

Chapter 3:  Opening an eSlide

Closing eSlides

To do this: Do this:

Closing a single eSlide If you have multiple eSlides open, click the one you want to close in the 
filmstrip. If you only have one eSlide open, it is already selected. Go to the File 
menu and select Close Image. 

Closing all eSlides Go to the File menu and select Close All Images. 

If you made any changes to the eSlide (for example, you added or changed an annotation), you are asked if you want to save 
the changes before you close the slide. You can configure ImageScope to always save annotations when you close an image 
without asking you for confirmation.  See “Automatically Saving Annotations” on page 129  for instructions.

For More Information
`` For a quick reference list of the ImageScope toolbar, see “ImageScope Toolbar Quick Reference” on page 23.

`` To navigate and change magnification settings, see “Chapter 4: Viewing an eSlide” on page 22.

`` To adjust image color and brightness, see “Chapter 6: Making Image Adjustments” on page 36 .

`` To annotate an eSlide, see “Chapter 9: Annotating eSlides” on page 55 .

`` To save a snapshot of an eSlide you have modified or to save a portion of an eSlide, see “Chapter 13: Saving 
eSlides and Regions” on page 77. 
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This chapter introduces you to using ImageScope by giving a tour of the ImageScope main window and 
showing you how to use the navigation and magnification tools.

ImageScope Viewing Window

Toolbar

eSlide label

Zoom slider

Filmstrip Thumbnail

Magnifier

ImageScope main 
window pane

Status bar

The following describes the main elements of the ImageScope viewing window.

`` Toolbar – Many of the ImageScope commands and features are available on the toolbar. See the next section for a 
quick reference list of the ImageScope toolbar icons.

`` Zoom slider – You can magnify or shrink the current view. See “Zoom Slider” on page 28  for details.

4 Viewing an eSlide
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`` Filmstrip – The filmstrip shows what slides are open. You can move between eSlides by clicking the slide’s image 
in the filmstrip.

`` Label window – If an image of the slide label is associated with the eSlide, you can see it in the slide label 
window.

`` Thumbnail window –  eSlides are large and often you see only a portion of one in the ImageScope main window. 
The thumbnail is a view of the complete eSlide. See “Using the Thumbnail Window” on page 27.

`` Magnifier window – Move this tool to the area you are interested in to see a magnified view. See “Using the 
Magnifier Window” on page 28.

You can hide or show these tools from the View menu.

Clinical Viewing Mode
Clinical Viewing mode provides a simple toolbar that contains only the tools used in a clinical environment.

To do this: Do this:

Use the clinical toolbar Go to the View menu and select View Clinical Toolbar.

To provide quick and easy eSlide analysis, only the Summary View of the Annotations window 
is available when using clinical viewing mode.

Return to the full toolbar Go to the View menu and select View Standard Toolbar.

Adjusting the ImageScope Window

To adjust the ImageScope window to the size you prefer, grab the boundary of the window and drag it in or out. 

You can maximize, minimize/restore, or close the main ImageScope window or the individual eSlide window by using the 
standard Windows controls on the right. Use the icons on the left to access a menu to perform these actions.

ImageScope Toolbar Quick Reference

The following chapters discuss the ImageScope features in detail—here is a quick list of the toolbar buttons.

*These icons are shown in clinical viewing mode.

Tool Action
Go to the Open Image window where you can browse for a local eSlide to open for viewing.
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Tool Action
Close the eSlide that is currently being viewed in ImageScope.

Create a snapshot image of the eSlide currently being viewed.

Save an ImageScope view, the entire set of eSlides that is currently open in ImageScope, as a .sis file.  

Go to the Image Adjustment window where you can make color and other adjustments to the eSlide currently 
being viewed.
Go to the Image Information window, which displays information about the eSlide currently being viewed.

Go to the previous view of the eSlide.

Go to the next view of the eSlide (only enabled if you first used the back arrow to go to a previous view).

*Manually synchronize navigation for all eSlides you are viewing. (Used when multiple eSlides are open in the 
ImageScope window.)
*Use smart synchronization for multiple eSlides you are viewing. Corresponding regions in the eSlide images 
are synchronized. (Same icon as for manual synchronization, but colored yellow.)
Show or hide the magnifier window.

Show or hide the eSlide label window.

Show or hide the thumbnail window.

Show or hide the zoom slider.

Display on the full monitor screen. (Or turn off if already in full-screen mode.)

Show or hide axes or axes and grid.

*Open the Annotations window where you can create multiple annotation layers and organize and add 
descriptions to annotations.
Open the Annotation Link Manager window where you can link annotations or eSlides to create a viewing 
sequence.
Go to the previous link (if a previous link exists).

Go to the next link (if a next link exists).

Pan the eSlide.

Enable/disable Integrated Color Management. Only useful if the image contains an embedded ICC profile.

*Turn Image Quality (IQ) mode on or off.



ImageScope User’s Guide, Revision O © Leica Biosystems Imaging, Inc. 2014 25

Chapter 4:  Viewing an eSlide

Tool Action
Zoom the selected area of the eSlide.

*Extract a region of an eSlide.

*Draw a free-form annotation.

Draw a free-form annotation to be excluded from analysis. (This creates a negative annotation.)

*Measure an object on an eSlide.

*Draw a rectangular region (or a square if you hold down the Shift key while you draw).

Draw an elliptical annotation (or a circle if you hold down the Shift key while  you draw).

*Draw an arrow pointing to an area of interest.

*Select an image for a report. This feature is only useful if you have eSlide Manager Reporting option installed 
and the report template you are using uses images.
*See help information for ImageScope.

Full Screen Viewing
To view the eSlide with the maximum viewing area, go to the View menu and select Full Screen or click  on the 
ImageScope toolbar. The menu bar does not display in this mode.

To switch back to regular viewing mode, click  on the ImageScope toolbar.

Synchronizing Navigation of Multiple eSlides
You may want all of the open slides to show the same navigation behavior when you are viewing them side by side. (For 
example, if you pan to the right in one slide, every other eSlide also pans to the right.) 

To synchronize navigation when multiple slides are open, go to the ImageScope toolbar and click . 

Smart Synchronization

Smart synchronization compensates for rotation (non-flipped) but not for other factors such as 
stretched or missing tissue. In those cases, ImageScope tries to display the same tissue feature in all 
tiled images, but not necessarily in exactly the same location.

Smart synchronization is an extension of the manual synchronization feature discussed above.

Click the  icon on the ImageScope toolbar to use smart synchronization. (Notice that the smart synchronization icon is 
the same as the manual synchronization icon except that it is colored yellow.) Smart synchronization differs from manual 
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synchronization—not only is navigation synchronized between the slides, but corresponding regions in the eSlide images 
are also synchronized.

This feature is useful when you have multiple eSlides scanned from microscope slides that were prepared from the same 
tissue block but are stained differently. For example, below are two images of slides made from the same block. Using smart 
synchronization, the main features of the slide stay locked in step as the operator moves through the slides. 

Although smart synchronization compensates for most of the rotation orientations made with the ImageScope rotation tool, 
it cannot compensate for “flipped” images, where you have used the rotation tool to flip the image vertically or horizontally 
on its axis. If you try to use smart synchronization on such images or try to “flip” images when smart synchronization is in 
effect, ImageScope alerts you that flipped image rotations are not supported while SmartSync is active.

Moving the Viewing Area
ImageScope offers many different options for moving around an eSlide.

This feature: Works like this:

Panning Hold down the mouse button and drag the cursor across the eSlide. Panning 
moves the slide the direction you are dragging.

Panning tips:

yy If you can’t pan the image, you may have an annotation tool selected. Click 
the  icon on the ImageScope toolbar and try again.
yy As you pan, the black rectangle in the thumbnail image moves to indicate 

the section of the slide you are viewing.
yy If you want to set ImageScope to pan in reverse (“pathologist mode”), 

see“Panning Options” on page 128.
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This feature: Works like this:

Autopanning Autopanning enables you to move at high speed over an eSlide.

With the cursor at the center of the main viewing area, click the scroll wheel on 
your mouse or right-click and select Autopan from the menu that appears. 

A small navigation icon displays: , and you also see a darker version showing 
your cursor position: . Move the mouse in the direction you want to pan. Click 
anywhere to stop autopanning.

Scrolling You can scroll across an eSlide to the right, left, up, or down. As you move your 
cursor toward the edge of the ImageScope main window, the cursor changes to 
an arrow: ; click and hold the mouse button down to scroll in that direction. To 
stop scrolling, release the mouse button. 

Using the Thumbnail Window The thumbnail window shows the entire eSlide. The small black rectangle 
inside the thumbnail represents the area of the eSlide that appears in the main 
window. Click an area in the thumbnail window that you want to view, or drag 
the rectangle in the thumbnail window to move to another area of the eSlide. 

Drag the rectangle to 
move to a new area on 
the eSlide

To resize the thumbnail, click the lower left corner of the window. When you see 
a double-ended arrow, click and drag to resize the window. 

Moving to a specific point on the 
eSlide

Go to the Image menu and select Go To. Using the current image size displayed 
as a guide, type an X Coordinate (horizontal) and a Y Coordinate (vertical) in 
pixels.

yy Click Go To: Center to position the point selected by those coordinates in 
the center of the current view.
yy Click Go To: Corner to position the point selected by those coordinates in 

the upper left corner of the current view.

Page panning Use the Shift+Arrow keys to move a page to the right or left, or up or down.
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This feature: Works like this:

Using the Filmstrip To move between multiple eSlides in ImageScope, click an image from the 
filmstrip. 

Using the Magnifier Window
Use the magnifier window to show a larger view of a particular portion of the eSlide. To use the Magnifier window:

`` Drag the magnifier window on the main window to the area you want to see in more detail. Or move the cursor 
on the main image to the area you want to see in more detail, and the area at the current cursor location appears 
magnified in the magnifier window.

`` Resize the magnifier window by dragging its lower right corner.

The magnifier window’s default magnification is twice the resolution of the image in the main window. If the main window 
is at 20x magnification, the magnifier window shows 40x. You can change the resolution of the magnifier window by going 
to the Tools menu and selecting Options. For details, see “Magnification” on page 125.

Changing Viewing Magnification
You can change the resolution of the entire main window image.

Use this feature: To do this:

Immediate Maximum Zoom Double-click the image in the main window to immediately zoom that image to the 
maximum magnification. Double-click again to return to the most recent magnification that 
was not the maximum magnification.
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Use this feature: To do this:

Zoom Slider You can adjust the magnification of the entire display by using the zoom slider.

yy Click Fit to set the magnification to 0x and fit the entire eSlide within 
the main viewing area.
yy Click a setting to zoom in using that magnification.
yy Drag the slider up or down to change the magnification.
yy Click the image in the main window and roll the scroll wheel.

You can set zoom slider magnification to percentages by going to the Tools 
menu and selecting Options. 

Clear the Use “X” magnification rather than “%” check box and click OK. 

Zoom keyboard shortcuts Use Ctrl+Minus key to zoom out, and Ctrl+Plus key to zoom in.

Zoom Navigation To zoom into a particular area of the eSlide, click  on the ImageScope toolbar. Click and 
drag in the main image window to draw a rectangle to outline the zoom area. 

If you are using fixed size annotations, press the Ctrl key while you click on the area you 
want to zoom into. See“Fixed Size Annotations” on page 128  for more information. 

Viewing with Color Management
Aperio Integrated Color Management controls the optical characteristics of your scanner and your display monitor to ensure 
the colors of the eSlides display accurately. For information on Aperio Integrated Color Management, see “Appendix B: 
Aperio Integrated Color Management” on page 136. 

By default, ImageScope uses the scanner’s source ICC profile embedded in the eSlide and the target ICC profile for your 
monitor to make sure the image displays in accurate color. The ICC profile is embedded in the eSlide image during scanning.

The ImageScope toolbar allows you to turn Integrated Color Management on or off:

`` Click the  icon on the ImageScope toolbar to turn color management on or off. If color management is enabled, 
the icon looks like this: ; if it is disabled, it looks like this: . 

`` If an image has an embedded ICC profile, the  symbol displays at the bottom of the image. If color management 
is turned off, the symbol on the image looks like this: .
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In the example below, color management is enabled. The image on the left does not have an embedded ICC profile, and the 
image on the right has an embedded ICC profile:

Viewing Scalebar, Axes, and Grid
You can view a scalebar, scale axes, or a grid on an image in ImageScope. A scalebar shows the scale of an image and is 
often used on maps to allow you to estimate the distance between two points.

The units and spacing are adjusted to correspond to the resolution of the image and the current zoom level. 

The zero point of the axes is in the center of the window; it is labeled with the current unit (for example, um for microns). If 
the resolution of the image is unknown, the units on the axes/grid are p (pixels), kp (kilopixels), or mp (megapixels). This is 
the case for photomicrographs and gross images before the resolution is set. The resolution on such images can be entered 
explicitly or by measuring a known item with a ruler (see  “Chapter 8: Image Resolution” on page 52).
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To enable the axes view:

1.	 Click  on the ImageScope toolbar or go to the View menu and select Scalebar/Axes/Grid. The axes markers 
appear along the side of the image.

2.	 Click the down arrow next to  to select whether you want to see the axes or the axes plus a grid or a scalebar.

An image with the axes and grid looks like this:

An image with a scalebar looks like this:

3.	 The icon on the toolbar changes to reflect the fact that the grid is displayed:   instead of . To turn the 
scalebar/axes/grid off, click the axes/grid icon or go to the View menu and select Scale Axes/Grid.
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Viewing eSlides with IQ
Aperio ePathology Image Quality (IQ) technology provides pathologists and other scientists who view eSlides the ability to 
customize the view of those slides to boost productivity and visual clarity by digitally adjusting the stain colors, viewing the 
individual stain images, and/or re-mixing the stains on the fly while they navigate the image.

IQ allows you to choose what view of the eSlide gives you the best results and makes it easier for you to identify the 
features of the slide you are most interested in. IQ is available when you have opened an eSlide in ImageScope from eSlide 
Manager.

IQ Features

IQ uses color processing—analyzing each pixel of the eSlide image—to identify stains and modify their appearance on the 
eSlide. Some of its features include the ability to:

`` View just a selected stain as you navigate the eSlide. IQ uses color deconvolution to separate the stains and 
present them as you pan or scroll about the image. 

`` Boost or dilute the displayed concentration (especially useful for overstained or understained slides, or to suit your 
personal preference).

`` Enhance cellular detail such as nuclei.

`` Digitally adjust individual stain colors for visual clarity and personal preferences (for example, darker/lighter, more 
or less vibrant, bluer/redder, and so on).

IQ Quick Reference

To turn on IQ for the image in the ImageScope window, click  on the toolbar. You can then select the stain set to use to 
view this eSlide by clicking the down-arrow next to the  icon:

The default stain set is optimized for Hematoxylin and Eosin stains.

To use the IQ viewing toolbar and application:

1.	 With IQ turned on, go to the Image menu and select Quality. The IQ viewing toolbar appears:

2.	 Click the buttons to view the eSlide using all stains or individual stains.
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3.	 To see the full IQ user interface, click the Details button on the viewing toolbar:

You can use the IQ tabs to define the stains applied to the eSlide, re-mix and re-color those stains, create your own stain 
sets, and measure the stains used by your lab. To return to just the viewing toolbar, click View Only.

For details on using IQ, see the IQ Image Quality User’s Guide.
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ImageScope rotation tools allow you to rotate an image. You can also rotate an eSlide label image.

Rotating an Image
The rotation setting is in effect only for the current viewing session and is not saved with the image. However, when you 
create a new image by using the Snapshot or Extract Region commands, the new image is saved in the current rotation. 
Saving an Image View also saves the current rotation settings so that opening the Image View displays the image with 
those rotation settings applied.

Image rotation is not enabled during a TelePath Live session.

To use image rotation:

1.	 Go to the ImageScope Image menu and select Rotate Image (Ctrl+E). The Rotate Image toolbar appears:

2.	 From the rotation toolbar, select the rotation setting you want to use:

Rotate zero degrees

Rotate 90 degrees right

Rotate 180 degrees

Rotate 90 degrees left

Flip vertically

Rotate 90 degrees right and flip vertically

Flip horizontally

Rotate 90 degrees left and flip vertically

5 Rotating Images and Slide 
Labels
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Rotating a Label

You can rotate an eSlide label. Open an eSlide in ImageScope and position the cursor on one edge of the slide label. A small 
arrow displays: 

Double-click an arrow on the side of the label you want on top. When you save the eSlide, the label rotation is saved.
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You can modify the color settings of eSlides if particular colors do not show up well on your workstation 
monitor. This chapter discusses the different image adjustment settings.

For information on adjusting fluorescence images, see “Chapter 7: Working with Fluorescence 
eSlides” on page 40.

Image adjustments apply only to the current ImageScope session. Image adjustments do not modify your original eSlide, and 
they are not stored with the eSlide. You can save gamma settings to apply to the current eSlide or to apply to other eSlides 
later, and you can make a snapshot of the adjusted image if you want to save the adjusted eSlide image. (See “Chapter 
13: Saving eSlides and Regions” on page 77 for information on making snapshots.)

Use the image adjustments to:

`` Adjust the brightness or contrast for all colors or for just the red, green, or blue channel.

`` Modify the color balance (for example, make reds less red and more cyan).

`` Adjust color curves for all colors or for just the red, green, or blue channel.

`` Save the color adjustments you have made in a gamma table file so they can be re-applied to the same or other 
eSlides in future ImageScope sessions.

`` Make image adjustments to the entire eSlide or to Z-stack images. 

6 Making Image Adjustments
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Getting Started with Image Adjustments
To make image adjustments:

1.	 Go to the Image menu and select Adjustments or click  on the ImageScope toolbar. The Image Adjustments 
window displays:

General Tips

`` To modify the appearance of the entire eSlide, select Main Image. To modify just the current Z-stack images, 
select Z-stack Images. (For information on 3-dimensional Z-stack images, see “Chapter 17: TelePath Live” on 
page 112.)

`` Click and hold the Compare button to temporarily return the image to the original settings. Release the button to 
revert back to the changed settings. 

`` Click the Reset button to return all colors to the original default settings.

Making Image Adjustments
Follow the instructions below to make color adjustments to your eSlide images using the brightness and contrast, color 
balance, color curves adjustment. When you are finished making adjustments, click OK.
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To make this 
adjustment: Do this:

Brightness and 
Contrast

Go to the Brightness/Contrast tab.

1.	 Select the Red, Green, or Blue square to adjust 
the brightness or contrast for those specific 
color channels. Select Gray to adjust all color 
channels

2.	 Drag the sliders to decrease or increase the 
brightness or contrast levels or type a number 
in the Brightness or Contrast box. A negative 
number to decreases the level, and a positive 
number to increases the level.

Color Balance Go to the  Color Balance tab:

1.	 Drag the sliders to adjust the color balance in 
the red, green, and blue channels. Or type a 
number in the color boxes. A negative number 
moves the balance to the left, and a positive 
number to moves it to the right.

2.	 Select the Keep brightness constant 
check box to adjust all color channels as one 
channel’s intensity is adjusted. To adjust the 
intensity of each color independently, clear this 
check box.

Color Curves Go to the Color Curves tab:

1.	 Select the Red, Green, or Blue square to adjust 
the brightness or contrast for those specific 
color channels. Select Gray to adjust all color 
channels.

2.	 Edit the curve by clicking the pencil tool  to 
draw a free-form shape, or select the points 
tool  to create and drag points. 

In this example, we selected the red channel, then 
created and dragged a point down to change the 
red channel curve. The In and Out boxes indicate 
the current cursor position on the curve.
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Saving and Loading Color Settings
You can save all of the image adjustments you made on the other Image Adjustments tabs on the Load/Save tab. You can 
also load and apply settings you previously saved to the current image.

On the Image Adjustments window, click the Load/Save tab. 

To do this: Do this:

Save the color adjustment settings To save the current color adjustment settings:

1.	 Click Save. 

2.	 On the Save Gamma Tables window, navigate to the directory where you 
want to save the gamma table file, type a file name, and click Save.

3.	 Click OK to exit the Image Adjustments window.

Load color adjustment settings To load previous settings:

1.	 Click Load. 

2.	 On the Load Gamma Tables window, navigate to the location of a 
previously saved gamma table file, and select a file, and click Open.

3.	 Click OK to exit the Image Adjustments window.

For More Information
`` For information on Z-stacks, see “Chapter 17: TelePath Live” on page 112.

`` For information on loading color settings to be used every time ImageScope opens, see “Default Gamma Files” on 
page 126.
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This chapter discusses how to view and adjust fluorescence eSlide images.

Images from the Aperio FL are grayscale images that are pseudo-colored during the scanning process.

ImageScope offers a full range of fluorescence features:

`` Temporarily apply a false color to a fluorescence image (this is not needed for fluorescence eSlides created by the  
Aperio FL)

`` For a fused image:

yy Change the display color for each channel image

yy Adjust brightness, contrast, and gamma (viewing the results on the image and on a histogram display)

yy Adjust registration between channels

`` Fuse multiple fluorescence channel images into a fused image (automatically done for images acquired with the 
Aperio FL)

Applying a Temporary False Color
If you are using a grayscale fluorescence image and want to display it in color:

1.	 Open the image in ImageScope.

2.	 Go to the Image menu and select False Color. The False Color window displays:

3.	 Select a color by clicking a color box or using the color slider. 

4.	 Select the Enable check box to see the image in the color you have selected. To view the image without the false 
color, clear the Enable check box.

Applying a false color in this way does not permanently change the display color for the image—this adjustment applies 
only to the current ImageScope viewing session. 

7 Working with Fluorescence 
eSlides
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Adjusting Fluorescence Fused Images
Fluorescence images are displayed in ImageScope using the color, brightness, contrast, and registration settings made in 
the scanner Console when the scan was made. 

Any changes you make on the Image Fusion Adjustments window are saved with the image so that they apply the next time 
you open the image in ImageScope.

To use the Image Fusion Adjustments window:

1.	 Open an Aperio Fused Image (AFI) in ImageScope. The usual way to do this is from eSlide Manager. Note that the 
AFI is indicated by the  symbol in the eSlide Manager eSlide list.

2.	 Go to the ImageScope Image menu and select Fusion Adjustments (only available if viewing an AFI) to open the 
Image Fusion Adjustments window:

The fused image is at the top, and the individual channels that make up that image appear below the fused image.

Using the Fusion Adjustment Window

You can enable features by clicking the symbols on the Image Fusion Adjustments window (see the following sections for 
details on using each of these tools):

If at least one channel is hidden, this button cycles between the channels, showing different combinations.

Show/hide color pane.

Show/hide brightness, contrast, gamma adjustment pane.

Show/hide registration pane.

Show the channel images that make up the AFI.

On each secondary pane, click   to reset the image to the original image settings (at the time the image was scanned). If 
the fused image is selected, this button resets all channels. 
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Before using one of the options at the bottom of the window, select a channel so that the changes you make apply to that 
channel image. 

After opening a tool pane, click  to close the pane to exit back to the main Image Fusion Adjustments window.

Viewing All Channel Images

eSlide Manager displays only the AFI and not the channel images that comprise the AFI for fluorescence images that were 
created by scanning a glass slide on a Aperio FL.

If you need to view the channel images that comprise an AFI, you can do so by using ImageScope.

1.	 Open the AFI in ImageScope by clicking its thumbnail on the eSlide Manager page. You see the AFI in the main 
ImageScope window along with the Image Fusion Adjustment window:

2.	 To view all of the channel images that make up the AFI, click the channel tile icon  on the Image Fusion 
Adjustment window. All of the channel images are tiled in ImageScope:
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3.	 You can make channel adjustments, as described below.

To make this adjustment: Do this:

Hide a channel To hide a channel, click the eye symbol:  next to it. (To add it back to the 
display, click  again.)

Notice the difference in the image with the FITC channel hidden (on the right).

Hide a channel color Click the color box next to a channel to turn off the false color for that channel 
(that is, to display it in grayscale). To turn the false color on, click the color box 
again. 

Notice the difference in the image with the FITC channel displayed in grayscale 
(on the right).
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To make this adjustment: Do this:

Hide all color To remove all color, click the color box next to the AFI:

Seeing Channel Information

Place the cursor on a color box to see information about that channel.

Cycling Channel Displays

To cycle the display among the channels:

1.	 Hide a channel by clicking the eye symbol:  next to it. 

2.	 Click the  button to cycle among different combinations of channels. 
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In the example below the FITC channel is hidden (this also automatically 
turns off the AFI fused image as all channels must be on to see the fused 
image):

Clicking the  button cycles the display to a new combination of channels 
(TRITC and FTIC).

Clicking the  button again cycles the display to another combination of channels. To turn off cycling, manually turn on all 
channels by clicking the  next to hidden channels.

Adjusting Color

To change false colors, on the Image Fusion Adjustments window, click . On the color adjustment window, select a 
channel and select the color to be used to display that channel by clicking a color box on the Color Adjustment pane or using 
the color slider.

Click  to invert color intensity in the display—the brightest pixels in the selected color become dark and the darkest 
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pixels become bright. If a channel has been inverted, a small inversion symbol displays next to the color box for the channel.

For example: 

Adjusting Brightness, Contrast, and Gamma

To adjust brightness, contrast, and gamma, click . You may want to change these settings to eliminate background 
noise, boost a weak signal, assign a histogram stretch, and so on. These settings affect the display of the fused image and 
channel images, but do not affect the actual pixel data in the image files.

`` Brightness – This setting adjusts the overall intensity of every pixel. You may want to use this to brighten dark 
images or darken bright images.

`` Contrast – This setting makes the dark pixels darker and the light pixels lighter. 

`` Gamma – This setting changes the midtones of your image. It is a nonlinear adjustment that can make faint 
objects more intense without saturating bright objects. At the same time, medium-intensity objects can be made 
fainter without dimming the bright objects.

A typical way of using these settings it to first adjust the contrast to stretch the intensity of the image and then, if the image 
is too bright or dark, adjust the gamma.

The best way to see the effect of the settings is just to try them on your image to see what improves the image.

Select a channel (or the fused image) and select the settings you want to use. You can make these changes with color 
turned on or off. Any adjustments you make are immediately visible in the image in the ImageScope window.

`` To see an intensity histogram of the current view of the image, click . (See “The Intensity Histogram” below.)

`` To turn automatic contrast settings for the image thumbnail on or off, click  (“Th” stands for “thumbnail”). 
Automatic contrast for thumbnails is on by default to boost contrast, as thumbnails tend to be very dark. 

Brightness, contrast, and gamma settings are applied to the thumbnail only if Auto Contrast is off. 



ImageScope User’s Guide, Revision O © Leica Biosystems Imaging, Inc. 2014 47

Chapter 7:  Working with Fluorescence eSlides

If this setting is not beneficial to the visual quality of your particular image, turn it off. This setting is used not 
just by ImageScope, but also by eSlide Manager when displaying thumbnails, so turning it off in ImageScope also 
affects thumbnail display in eSlide Manager or any other Aperio ePathology application that displays thumbnail 
images. Once turned off, the setting stays off for this image until you turn it on again.

`` To compare the new settings against the original, click .

Intensity Histogram

To see a histogram of the current image view, click the  button. 

The histogram plots the number of pixels at each intensity. By looking at the left of the histogram you can see how many 
pixels are in the darkest intensity; the right of the histogram shows how many pixels are in the lightest intensity.

The black line shows a transfer function that relates input to output. You might also know this line as the tone curve. In an 
unadjusted image, this line is a straight line from zero to maximum intensity. As you change settings, the line changes to 
reflect your adjustments.

The Low Clip and High Clip sliders allow you to set thresholds. For example, the Low Clip slider sets a lower threshold 
point—if any pixels fall below that value they are forced to zero. This is often used to eliminate noise (the “noisy” pixels 
that do not convey real information are simply forced to black). The High Clip slider sets an upper threshold point—if any 
pixels fall above that value they are forced to the maximum value (white).



ImageScope User’s Guide, Revision O © Leica Biosystems Imaging, Inc. 201448

Chapter 7:  Working with Fluorescence eSlides

For example, in the image shown above, we adjusted the gamma on the DAPI channel to lighten the midtones.

Now we move the Low Clip slider to eliminate noise in the lower intensities:

Adjusting Registration

Fluorescence images acquired on the Aperio FL using the quad multi-bandpass filter cube should be perfectly registered. 
Images acquired using single-bandpass filter cubes or images imported from other sources may require registration changes 
so that the channels are aligned correctly. 

To see the registration pane, click  on the Image Fusion Adjustments window.

Select the channel you want to register. (In the example above, DAPI is selected.)

`` Use the arrows to move the image pixel by pixel in the X or Y axis. The arrows closest to the center of the arrow 
strip move the image by one pixel, the next arrows move it by 10, and the arrows at the end of the arrow strip 
move it by 100 pixels.

`` Click the 0 at the center of the arrow strip to move the image back to its original position on that axis.

`` The colored box in the middle of the display shows the position of the image relative to its original position. 
The box starts in the center and moves as you use the arrows. The color of the border of the box tells you which 
channel you are working with. (In the example above, the blue border is the same color used for the channel DAPI, 
so we know we are working with that channel.) 
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`` The movement of the image in the X/Y axes is shown in the X and Y boxes.

Fusing Fluorescence Images
The scanner creates a multi-layer “fused” image made up of the individual channel images. However, you can also use 
ImageScope to create your own fused image or create one from individual channel images you received from another 
source.

Our example shows opening images in eSlide Manager.

1.	 Log into eSlide Manager and select All eSlides (As List) from the eSlides menu.

2.	 Select the check boxes next to the channel images you want to use to create a fused image and click View 
Images.

ImageScope opens each of the selected images:

In this example, we have three images, one for each type of fluorochrome used to stain the slide: DAPI, FITC, and 
TRITC.

If you want ImageScope to keep each of these images open after it creates the fused image, click the first image to 
select it, go to the Image menu, and select Keep Open (or type Ctrl+K). Repeat for the other images.

3.	 On the ImageScope menu bar, go to the Image menu and select Fuse Images.

4.	 On the Remote Image List Box, select all channel images that comprise the fluorescence scan:
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This window does not ask you for a file name or description if you opened the images directly from your local 
workstation or network location as ImageScope automatically assigns a file name based on the base file name of 
the channels when working with local images.

5.	 Type a file name to use for the AFI file and, optionally, a description.

If the channel images belong to more than one eSlide, this window asks you to choose which eSlide to add the 
fused image to. 

6.	 Click Fuse Selected Images. This creates an AFI. ImageScope opens the AFI and displays it in the main window:
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When you close ImageScope and return to eSlide Manager, you see the AFI listed in the eSlide list:

The AFI is indicated by the  symbol.

Notes on Creating an AFI

When you are manually fusing channel images into an AFI, note that all of the channel image files and the new AFI file must 
reside in the same network/server directory, and this directory must be in the ImageServer’s root directory as defined by the 
ImagServer’s  -dir option in the ImageServer configuration file.

If you want the new AFI to reside and be visible in eSlide Manager, you must open the individual channel images from 
within eSlide Manager, and then fuse them in ImageScope.
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This chapter discusses how to see the resolution of an image and, if it is not known, how to set it.

For eSlides created by scanning microscope slides on an Aperio scanner, the resolution of the image is known and is stored 
in the image file. The resolution is used to display the magnification in the zoom slider, to compute ruler values, and to 
compute the length and area of annotation regions.

The resolution may not be known for other types of images you are working with. 

To view and set an image’s resolution:

1.	 Go to the Image menu and select Resolution. The Image Resolution window displays:

If the resolution of the image is stored within the image file, Current Image Resolution and Apparent 
Magnification contains values—if the resolution is not known, these boxes will be empty.

Setting or Changing Image Resolution

When you change the resolution, you affect the way an image is viewed, but do not change the image 
file or information stored in it.

Because the resolution is used to display the magnification in the zoom slider, to compute ruler values, 
and to compute the length and width of annotations, these values change when you change the 
resolution.
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You can use the options on this window to change or set the image resolution:

`` Use Resolution Specified in Image File – If the resolution is stored in the image file (for example, it was 
created by scanning a glass slide on an Aperio scanner), select this option to reset the resolution to the value 
stored in the file.

`` Manually Enter Image Resolution (or Magnification) – If you know the resolution for the image, select this 
option and type the image resolution and apparent magnification values in the boxes at the top of the window.

`` Compute from Currently Selected Annotation Ruler – You can determine the resolution of the image from an 
object of known size in the scanned image. See the next section.

Computing the Resolution from the Image
If you select the Compute from Currently Selected Annotation Ruler option in the Image Resolution window, you can 
use an object of known size in the image to calibrate the image resolution.

For example, in the following image a scale is part of the picture:

1.	 Draw an annotation ruler across the scale, which in this case shows a length of 5 centimeters. 

2.	 Go to the Image menu and select Resolution. The Image Resolution window now has a place for you to enter the 
length of the ruler:
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3.	 On the Image Resolution window, select Compute from Currently Selected Annotation Ruler and enter the 
length of the ruler in microns. In this case, enter a value of 50000 (5 cm = 50000 microns). If you want to delete the 
ruler after calibration, select the Delete Ruler after Resolution Computed check box.

Now all values measured by rulers will be accurately calibrated to this scale, such as the second ruler shown above which 
measures a length of 31mm across the specimen.
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Annotations direct attention to interesting elements of an eSlide. This chapter contains basic information 
on creating annotations. See the next chapter for advanced annotation information on moving and deleting 
annotations, using annotation layers to organize annotations, and storing algorithm analysis results.

Annotations can define a region of the eSlide you are interested in, measure an object, or point to an interesting area. You 
also use annotations to define the areas of an eSlide on which to perform an algorithm analysis or to define the areas on 
which not to perform an analysis.

To add an annotation to an eSlide, use the drawing tools on the ImageScope toolbar. (You can also right-click in the image, 
and select a drawing tool from the menu that appears.) 

Ellipsis (or circle if you hold down the Shift key while drawing)

Rectangle (or square if you hold down the Shift key while drawing)

Free-form shape

Arrow

Measurement

Select an eSlide Manager report image

Drawing Fixed Size Annotations
If you have predefined a fixed size, hold down the Ctrl key while you draw the annotation to use that size. (This works with 
the rectangle, ellipse, arrow, report image, and ruler annotations.) 

See “Fixed Size Annotations” on page 128  and “Report Image Options” on page 131  for information on setting a fixed 
size for annotations.

Drawing Annotations with a Fixed Aspect Ratio
Drawing an image in a specific aspect ratio (or capturing an image in a fixed aspect ratio) can be useful when preparing an 
image for a publication.

To draw an image that uses the same aspect ratio as the fixed size you defined for annotations, press the Shift key and the 
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Ctrl key while you draw the annotation. For example, if you specify a fixed annotation size of 400 pixels wide and 300 pixels 
high, when you press Shift and Ctrl and draw an annotation, it always has a ratio of 400 to 300 (4:3), regardless of its size.

You can also use the Shift and Ctrl keys to extract a region of a specific aspect ratio. See “Extracting an Image of a 
Predefined Size or Aspect Ratio” on page 83.

To set a fixed size for annotations (and thus a fixed aspect ratio), see“Fixed Size Annotations” on page 128.

Free-form Drawing

To draw a free-form shape on an eSlide, click   on the toolbar and then click and drag in 
the main window to draw your shape. Release the pen when you have finished the shape.

Measuring Objects
To measure an object on the eSlide, click  on the toolbar, and then click and drag the 
ruler over the object.

The ruler adjusts for the current resolution. When you measure with the image displayed at 
lower magnifications, such as 2x, the ruler displays in millimeters rather than microns. The 
ruler tool may not work on images that were not created by the Aperio scanner. 

Drawing an Arrow
To draw an arrow, click   on the toolbar, and then click and drag away from the area to 
which you want the arrow to point. 

Drawing with the Negative Pen
The negative pen tool is used to draw negative free-form shapes. These are used in 
algorithm analysis to designate areas not to analyze.

To draw a negative shape on the eSlide, click   on the toolbar, and then click and drag 
in the main window to draw your shape. Release the mouse button when you are finished. 
A negative region is indicated on the display by a dashed line.

In this example, the rectangle indicates the region to analyze. The negative pen is used to 
draw an area within the region to exclude from analysis.
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Selecting an eSlide Manager Report Image
ImageScope allows you to select a specific image from an eSlide or specimen to be used in a report that includes that 
image. 

With an eSlide or specimen image open in ImageScope, click the   icon on the 
ImageScope toolbar and then click the area of the image that you want to display 
in a report. The area selected is saved as an annotation with the text label “Report 
Image.” Only one report image can be selected for a single image, and the report 
template you are using must contain images in order for this image to display.

To draw an area of a fixed size, press the Ctrl key while you draw. See “Report Image 
Options” on page 131 for information on setting the fixed size of a report image.

The report image displays on the image in the ImageScope window if you have 
annotation view enabled. As with all annotations, you can delete it or move it. 

Panning While Annotating
If you need to draw an annotation that is larger than the current window in ImageScope, drag the annotation drawing 
tool—as you reach the edge of the image in the ImageScope window, the image moves in the same direction as your cursor 
to allow you to continue drawing.

For More Information
`` See “Using the Annotations Window” on page 58 for information on other things you can do with annotations.

yy Add text to an annotation

yy Delete or move an annotation

yy Export or import annotations

yy Define annotation attributes to add information to an annotation

`` For information on creating viewing sequences, see “Chapter 11: Linking Annotations and eSlides” on page 
69.

`` When analyzing eSlides, you can use free-form or rectangle annotations to define what areas to analyze or use the 
free-form negative pen tool to define what areas not to analyze. See “Chapter 14: Analyzing eSlides” on page 
86.
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Window

Annotation layers are useful for organizing annotations and for storing algorithm analysis results. The 
ImageScope Annotations window shows you the annotations associated with the image.

ImageScope stores annotations in layers. You can use layers to organize annotations by reviewer or department so that each 
person’s or group’s annotations are on a different layer, and then:

`` Hide or show specific layers for different uses of the eSlide.

`` Delete only a specific annotation layer.

Annotation layers are also where algorithm analysis results are stored as quantitative data (see “Chapter 14: Analyzing 
eSlides” on page 86 ).

Annotations made on different layers are drawn in different colors. See below for information on changing annotation layer 
colors.

To open the Annotations window go to the View menu and select Annotations or type Ctrl+N. You can use the Annotations 
window in one of two modes:

`` Summary View – Designed for use with the eIHC product to provide one-step annotation and analysis for IHC 
eSlides. However, this view can also be used for quick analysis of any type.

`` Detailed View – Complete details on all annotations are available and you can add annotation attributes, text 
labels, and so on.

Annotations Summary View Window – Quick eIHC Analysis
The ImageScope detailed Annotations window provides a general solution for image analysis and handling annotations. 
However, a more streamlined version of the Annotations window is also available—the Annotations summary view. The 
Annotations summary view was specifically developed for analyzing IHC eSlides and makes the process quicker and simpler 
by fitting into a pathologist’s or researcher’s standard workflow. 

Slide-Specific Processing
The key to the eIHC workflow is slide-specific processing, which defines how an eSlide is processed based on its stain and 
type of tissue (body site). Slide-specific processing can define what algorithm is used to analyze that type of slide, how 
analysis results are displayed and how to interpret those results (alternatively, manual scoring can be set up for the slide), 
and what comments are available for use by the pathologist or researcher viewing the slide. The slide-specific configuration 
for each stain/body site combination is defined by the eSlide Manager administrator. Once slide-specific processing is set 
up, viewing, annotating, and analyzing an eSlide becomes a quick process.

The summary view of the Annotations window is designed specifically for working with IHC eSlides to provide a quick way 
to mark tumor regions and analyze them in one simple step.
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Using the Annotations Summary View Window

To open the Annotations window in summary view:

1.	 Identify an eSlide in eSlide Manager for which stain/body site slide-specific processing is defined.

2.	 From the eSlide Manager page, open the eSlide in ImageScope by clicking its thumbnail. The Annotations window 
in summary view displays. (If the window does not look like this, click the Summary button to access the summary 
view.)

The appropriate algorithm for this type of slide is listed in the drop-down box. You can select another algorithm from the list. 

Note that if you are in clinical viewing mode, the summary view Annotations window is the only view you can see. From this 
window you can draw annotations to identify areas to analyze and run the analysis:

1.	 With the algorithm that you want to use shown in the drop-down list, use the ImageScope pen or rectangle 
drawing tools to draw the areas of the eSlide you want to analyze.

2.	 To navigate between annotations, use the numbered buttons or arrow keys. (As you draw annotations with the 
analysis algorithm shown in the drop-down box, the buttons at the top of the window display a number for each 
annotation.) 

 

`` Click a numbered button to center the corresponding annotation in the ImageScope window.

`` Move between the annotations by using the arrow keys.

`` To delete the selected annotation click . To delete all annotations, click .
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`` To hide the selected annotation on the ImageScope window, click .

`` To save the annotations to eSlide Manager, click .

3.	 To analyze the current eSlide with the algorithm shown in the drop-down box:

a.	 Select the annotation drawn around the area you want to analyze and select Selected Annotation. (Or, if you 
want to analyze the entire area shown in the ImageScope window, select Current Screen.)

b.	 Click Run Analysis. As the analysis runs, you see progress information:

When the analysis is complete, you see the results:
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Enabling and Disabling Pre-processing

When using the Annotations window in summary view, you can temporarily turn off pre-processing region finding for 
algorithms that support that feature (for example, if you want to select possible tumor areas yourself to analyze rather than 
allowing the algorithm to do it for you).

To disable pre-processing, open the Annotations window in summary view and click the pre-processing button:

To turn pre-processing on again, click the button again. Note that this button is only enabled when you are using an 
algorithm that supports pre-processing.

Incremental Processing

The eIHC analysis applications are incremental algorithms, which means that as you add new regions and click Run 
Analysis on the Annotations window, only the new regions are analyzed, which can save a great deal of time. Any time you 
click Run Analysis again, all analysis results are updated.

Incremental processing is useful when a pathologist draws a single region and analyzes it, and after reviewing the analysis 
results wants to select additional regions and analyze them as well. The pathologist can add more annotation regions as 
needed or delete annotation regions and the analysis results will be updated accordingly.

If you delete a region, ImageScope automatically re-runs the analysis to update the summary analysis results that included 
that region. However, adding regions may make the analysis results incorrect until you re-run the analysis.

Other Options

`` To see a report image you have selected, select Report Image from the drop-down list.

`` To create an annotation that is not used for analysis (for example, a ruler or arrow), select Annotations from the 
drop-down list before drawing.

`` If the algorithm you are using supports result plots and they are enabled, the summary view window automatically 
opens all plots in separate windows when the analysis is done.
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Annotations Detailed View 
To see information on the annotation layers attached to an eSlide and to work with those layers:

1.	 Open the eSlide you want to work with. 

2.	 Go to the View menu and select Annotations. 

The following Annotations window shows an eSlide for which two layers have been created, “Dr. Bradley” and “Dr. Garcia”. 
(If the window does not look like this, click the Details button to return the Annotations window to the detailed view.)

`` Layers – lists all defined layers for this eSlide. To select a layer to work with, click it in the list. 

`` Layer Attributes – enables you to add and delete attributes for a layer. 

`` Layer Regions – enables you to add and delete attributes for an annotation. You can also select an annotation so 
you can delete or move it. 

Here is a quick reference guide to the features of this window (more details are provided later in this section):

This tool: Is located here: And enables you to:
Annotations window toolbar Arrange the Annotations window panes side by side, horizontally.

Annotations window toolbar Arrange the Annotations window panes vertically.

Annotations window toolbar Make Annotations window transparent so eSlide shows through.

Layers pane Change the color of the annotations in the selected layer. (This box shows 
the current color for the layer annotations.)

Layers pane Hide or show the annotations on the selected layer in the ImageScope 
main window.

Annotations window toolbar Save all annotations with the eSlide.

Annotations window toolbar Import annotations from a previously exported annotation file.

Annotations window toolbar Export the current annotations to an annotation file. Saved as XML with 
the same name as the eSlide file.

Layer Attributes pane
Layer Regions pane

Export the contents of the pane to a text file.

Layer Attributes Pane Display algorithm result plots.
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This tool: Is located here: And enables you to:
Layer Attributes pane
Layer Regions pane

Export the contents of the pane as an Excel spreadsheet.

Layers pane 
Layer Attributes pane 
Layer Regions pane

Add:
New layer (if on the Layers pane)
New layer attribute (if on the Layer Attributes pane)
New annotation attribute (if on the Layer Regions pane)

Layer Attributes pane 
Layer Regions pane

Delete:
Layer attribute (if on the Layer Attributes pane)
Annotation attribute (if on the Layer Regions pane) 

Layers pane 
Layer Regions pane

Delete:
Selected layer (if on the Layers pane)
Selected annotation (if on the Layer Regions pane)

Layers pane Delete all layers.

Configuring the Annotations Window

There are several ways to configure the Annotations window:

`` Click  to arrange the panes side by side, horizontally.

`` Click  to arrange the panes vertically.

`` Click the boundary between panes and drag it to expand or shrink the pan.

`` Within a pane, click the line between columns and drag it to expand or shrink the column.

`` Drag any outside boundary of the Annotations window to expand or shrink the overall window.

`` Click the transparent button  to make the Annotations window transparent.

Hiding or Showing Annotation Layers

To make an entire layer visible or invisible on the ImageScope main window, select the layer in the Layers pane and then 
click . 

Changing the Annotation Layer Color

All annotations created in a layer are displayed in the same color. 

To change the default colors used for each layer:

1.	 Go to the ImageScope Tools menu and select Options. 

2.	 Click the Annotations tab and click the color of the layer you want to change. 

3.	 Select a color to use from the Color window, and click OK.

To change the color used for a specific layer:
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1.	 In the Annotations window, select the layer in the Layers pane.

2.	 Click  to open a color selection window from which you can select the color you want to use. All annotations in 
that layer immediately change to the new color.

Annotation Length and Area Display

ImageScope measures and displays length and area for annotation regions. If the resolution of the image is known, length 
and area are displayed in microns; if not, they are displayed in pixels.

Adding Text to an Annotation

You can add a text note that appears with an annotation in ImageScope. 

If you do not want the text note for an annotation to appear on top of the annotation, draw the 
annotation in such a way that you finish the annotation in the upper right corner.

To add a text note:

1.	 In the Layers pane, select the layer that contains the annotation for which you want to add a note.

2.	 Click the annotation in the Layer Regions pane to which you want to add text.

3.	 Type the note into the Text column. 
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You can see the text note on the main window and in the Layer Regions pane of the Annotations window.

Adding and Deleting an Annotation Layer

To do this: Do this:

Create a new layer Click  in the Layers pane. To change the name of the layer, click the name and 
type a new name.

Delete a layer In the Layers pane, select the layer you want to delete and click .

Delete all layers Click  in the Layers pane to delete all layers.

Deleting Annotations

To delete an annotation, select the annotation in the main ImageScope window and then press the Delete key on your 
keyboard.

You can also delete n annotation from the Annotations window:

1.	 Go to the View menu and select Annotations.

2.	 Select the layer in the Layers pane that contains the annotation you want to delete.

3.	 In the Layer Regions pane, select the annotation that you want to delete, and then click .
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For example, to delete annotation 1 in the above example, select the  Dr. Bradley layer in the Layers pane, select 1 in the 
Layer Regions pane, and then click  in the Layer Regions pane. The blue bar in the example indicates the annotation is 
selected.

On the ImageScope main window:

A selected annotation looks like this, with a dark line in the middle of the annotation boundary.

An annotation that is not unselected looks like this.

 

Moving Annotations

You can move a single annotation or all annotations. 

To move: Do this:

One annotation With the annotation selected on the ImageScope window, press and hold the 
Ctrl key, then drag the annotation to a new location.

All annotations You can move all annotations at the same time. For example, if you import 
annotations from a similar eSlide, slight variations in the new slide might 
require adjusting the position of the imported annotations. 

On the ImageScope main window, press and hold the Ctrl and Shift keys, and 
drag an annotation to a new location. All annotations move with the one you are 
dragging.

All annotations in all layers will be moved except for Z-stacks and markup 
images.
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Saving Annotation Layer Changes

To save any changes you made to the annotations, click .

Exporting and Importing Annotation Layers

ImageScope provides several ways to export and import information and annotations.

Algorithm analysis results are stored in an annotation layer so you may want to export that information into a text file to 
include it in a report or to chart the information in a spreadsheet program.

You can also export annotations to be used on other eSlides. For example, if working with several very similar eSlides, you 
may find the same annotations apply to all of them.

Importing and Exporting Annotations

To export all of the annotations for the current 
eSlide:

On the Layers pane, click . Specify a name and location for the .xml 
file created.

To import an annotation file to the current 
eSlide:

On the Layers pane click . Navigate to the location of a previously 
exported annotations file.

Exporting Text from Annotations Window Panes

You can export a tab-delimited text file that you can import into a spreadsheet program.

To export the text of the Layer Attributes pane 
to a text file:

On the Layer Attributes pane, click . Specify the name and location of 
the text file to be created. 

To export the text of the Regions Attributes 
pane to a text file:

On the Regions Attributes pane, click . Specify the name and location 
of the text file to be created. 

Exporting Text from Annotations Window Panes to a Spreadsheet

Numeric data exported from the Annotations window to a spreadsheet is exported as text. Excel displays a note for each of 
these cells warning you that the numbers are in text format—when you click on the note you can opt to transform the text 
to numeric format.

To export the text of the Layer Attributes pane 
to a Microsoft Excel spreadsheet:

On the Layer Attributes pane, click . Specify the name and location of 
the spreadsheet .xls file to be created.

To export the text of the Regions Attributes 
pane to a Microsoft Excel spreadsheet:

On the Regions Attributes pane, click . Specify the name and location 
of the spreadsheet .xls file to be created.
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Adding and Deleting Attributes

Attributes are text fields that describe the layer or annotation. Several attributes are already defined. For example, the 
Layers pane and the Layer Regions pane both contain a Description attribute. By typing text in this column, you can include 
comments or a description of the layer or annotation. 

When multiple entries are defined for an attribute, you can sort the entries alphabetically by clicking the attribute title. In 
this example, we clicked Case# to sort the list of annotations by case number:

Adding Your Own Attributes

You can also add your own attributes (for example, slide routing information, test results, etc.). 

To add a new layer attribute: 1.	 On the Layers pane, select a layer.

2.	 On the Layer Attributes pane, click  to add a new attribute. 
Enter the name of the attribute in the window that appears. The 
new attribute is the title for a new column that contains a text 
field in which you can enter any data you wish.

To add a new annotation attribute: 1.	 On the Layers pane, select a layer.

2.	 On the Layer Regions pane, click  to add a new attribute. 
Enter the name of the attribute in the window that appears. The 
new attribute is the title for a new column containing a text field 
in which you can enter any data you wish.

Deleting Attributes

To delete a layer attribute: 1.	 On the Layers pane, select a layer.

2.	 On the Layer Attributes pane, select an attribute.

3.	 Click  to delete the selected attribute.

To delete an annotation attribute: 1.	 On the Layers pane, select a layer.

2.	 On the Layer Regions pane, select an attribute.

3.	 Click  to delete the selected attribute.
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eSlides

Creating a viewing sequence by linking eSlides and/or annotated regions is a powerful way to organize and 
present information.

Here are two sample uses of linking annotations and eSlides:

`` Create a path of views through a slide or group of slides that takes the viewer on a tour of highlighted features. 

`` Create a hierarchy of images, perhaps from gross specimen down through blocks and then to slides.

Links have the following characteristics:

`` Links can be associated with a region in an eSlide or with the entire image. 

`` Links have direction. If you traverse a link in the forward direction, you can follow the same link back.

`` You can create any number of links into or out of a region or image.

`` If there is more than one link to or from the currently selected annotation or slide, then the Link Manager window 
will open so that you can select a link.

`` You cannot create links for layers, only for eSlides or annotations.

Working with the Link Manager
To start the Link Manager, go to the View menu and select Annotation Links Manager.
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On the left side of the Link Manager window is a tree view of all eSlides open in ImageScope. The next level represents 
annotation layers, and the final level is annotations in that layer. For example, the first slide above, Ex3_40X.svs, contains 
two layers, “Dr. Bradley” and “Dr. Garcia.” The “Dr. Bradley” layer contains three annotations, “TB5/5/06,” “TB5/12/06,” 
and “TB5/12/06.”

Click + to expand the lists, and click – to collapse them.

When you click a node in the tree, any links for that node appear in the list on the right. 

Creating a Link
To create a link:

1.	 In the left pane of the Link Manager window, drag a node and drop it onto another node.

For example, we dragged the first annotation on the Dr. Bradley layer onto the second annotation to create a link:

The  symbol indicates that the link is a forward link. The  symbol indicates the link is a backward link.

Viewing Links

The link navigation icons and commands are only enabled if a link exists. For example, if no previous 
link exists, you cannot use the Previous Annotation Link command.

You can follow links either on the main ImageScope window or from within the Link Manager window. You do not need to 
open the Link Manager window to follow links.

If no annotation is selected, the viewing tools follow slide-level links; if there is more than one link to or from the selected 
annotation or slide, then the Link Manager window opens so that you can select a link.

ImageScope displays the target of the link in its main window. If the target is an eSlide, then it is fitted into the main 
window; if it is an annotation, then the annotation is centered and zoomed.
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To follow links in the main ImageScope 
window:

1.	 Open an eSlide that contains links.

2.	 To go to the next link, go to the View menu and select Next 
Annotation Link, or press Shift+F8, or click the  icon on the 
ImageScope toolbar.

3.	 To go to a previous link, go to the View menu and select Previous 
Annotation Link, or press Shift+F7, or click the  icon on the 
ImageScope toolbar.

To follow links in the Link Manager window: 1.	 Open an eSlide that contains links.

2.	 Go to the View menu and select Annotation Link Manager to 
open the Link Manager.

3.	 Click on the node for which links have been created and click  in 
the right pane of the Link Manager window to follow the link.

Deleting Links

To delete a single link: In the Link Manager window, select a link in the right pane of the window 
and click .

To delete all links: In the Link Manager window, click .
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The tracker tool enables you to record your movements through an eSlide and to save that record (known 
as a track) with the image as an annotation layer.

Typical uses for the tracker tool are:

`` Histologists and pathologists might use this tool as reminder of which sections of the eSlide were visited. 

`` The saved track might be useful for quality assurances purposes by providing permanent evidence of what sections 
of the eSlide were viewed.

`` The saved track could be used for educational purposes to provide students a tour of the eSlide.

Turning on the Tracker
To turn on the Tracker:

1.	 Go to the View menu and select Tracker. The tracker tool displays:

You can move this tool anywhere on your monitor display, even off the ImageScope window.

2.	 To start recording your movements, click the red record button :
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When the recording begins, the thumbnail image turns gray. As you move, each section of the image you move to 
is highlighted in the thumbnail. The intensity of the highlight shows the resolution at which that part of the image 
was viewed.

For example, after moving through several portions of the eSlide shown above, the thumbnail looks like this:

You can change the size of the thumbnail by dragging the lower left corner of the thumbnail window.

Tips:

`` If you do not want to see your progress mapped on the thumbnail, clear the Map check box on the tracker tool. To 
show or hide mapping, type Ctrl+M. You can also set the default value of this check box. See “Tracking Options” on 
page 129.

`` To automatically move to the next unviewed section, click  on the tracker tool. This button moves through 
the image in a similar way that a person would, working left to right, top to bottom. Using this button, you can 
systematically view the entire slide.

`` To stop recording, click  on the tracker tool.
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Viewing a Track
To view a track:

1.	 Go to the View menu and select Annotations. The Annotations window appears:

Each track associated with this eSlide is listed in the Layers pane of the Annotations window. To see information on each 
track, click a Track in the Layers pane.

Tips:

`` A + symbol after the Track name indicates the track recording is complete.

`` An * after the Track name indicates the track recording is still in progress.

`` An indented track (for example, Track 3 in the example above) indicates that the track is appended to the track 
above it. (See “Appending to a Track” on page 76 for information on appending.) 

`` The Layer Attributes pane shows when the selected track was recorded. 

`` The Layer Regions pane gives information on each stage of the recording. The first region of the track is the path 
that connects the center of all the views in the session. The other regions in the track are rectangles corresponding 
to each view in the session.

`` To see a track in the main ImageScope window, select the track in the Annotations window and click the eye icon 
at the top of the Layers pane.

`` As with any annotation layer, you can change the name of the track (for example instead of “Track 1+” you can 
name the track “Dr. David”) by clicking it and typing in a new name.
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Playing a Track
To play the current track:

1.	 Click  on the tracker tool.

To select a track made in the past:

1.	 Open an eSlide. 

2.	 Go to the View menu and select Annotations. The annotations window displays:

3.	 Select the track you want to play by clicking it in the Layers pane of the Annotations window.

4.	 Click  on the tracker tool.

Tips:

While playing a track, use the tracker tool buttons to affect the playback:

Stop playing or recording the track.

Go to first view in the track

Go to the last view in the track

Go to the next view in the track

Go to the previous view in the track

As you play the track, the Annotations window updates to show your location in the Layer Regions pane.
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Appending to a Track
You can either start a new recording or append to a previous one. If a track already exists for this eSlide, when you click the 
record button, a message appears asking if you want to append the new track to the selected track.

To start a new recording, click No; to append to the previous track, click Yes.

If more than one track is created for the eSlide, to append to a specific track, open the Annotations window and select that 
track in the Layers pane before clicking the record button.

When a track is appended, the recording starts off as if all the views in the parent track have been viewed.

See “Viewing a Track” on page 74 for an example of an appended track.
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This chapter discusses several different ways to save images of eSlides.

Taking a Snapshot
You can capture a picture of the eSlide you are viewing by using the Save Snapshot command. The image is saved in JPEG 
or TIFF format.

1.	 Navigate to the area of the eSlide you want to capture so that it appears in the main ImageScope window.

2.	 Go to the File menu and select Save Snapshot or click  on the toolbar.

3.	 In the Save Snapshot window, browse to the location where you want to save the file.

4.	 Type a name for the file in the File name box.

5.	 In the Save as Type drop-down list, select TIFF Files or JPEG Files, and click Save.

You can open and view the file from Windows Explorer or from within ImageScope.

Color Management

If you make a snapshot, and the original image has an embedded ICC profile:

`` If Integrated Color Management is turned on in ImageScope, then ImageScope transforms the image using the 
monitor ICC profile.

`` If Integrated Color Management is turned off in Image Scope, then ImageScope or embeds the scanner’s ICC 
profile.

Saving an Image to the System Clipboard
You can save the image currently being displayed to the system clipboard by going to the Edit menu and selecting Copy (or 
type Ctrl+C). You can then paste the image from the clipboard into an image processing application like Microsoft Paint or 
Adobe Photoshop.

Emailing a Snapshot
You can email the entire image displayed in the ImageScope window, or you can email snapshots of individual regions of 
the image.
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To email a snapshot:

1.	 To draw attention to specific areas of the eSlide, use the ImageScope rectangle drawing tool to mark those areas. 
For example:

2.	 Go to the File menu and select Email Snapshot. 

The Mail Snapshot window appears:

The first time you use this feature, if you have not already defined email settings for ImageScope, the SMTP Server 
tab of the ImageScope options appears so you can define this information. See “Email Settings” on page 133.

3.	 In the To: text box, type the email address of the person to whom you want to email the images.

4.	 Type a subject title for the email and any text you want to send in the email.

5.	 Under the Select Snapshot section:

a.	 Select Send current image view if you want to send the entire image currently displayed in the ImageScope 
window.

b.	 Select Send Regions in currently selected Annotation Layer if you want to also send separate images of 
the areas you drew rectangles around. (If you have previously drawn annotations on the image, see “Chapter 
10: Using the Annotations Window” on page 58 for information on selecting a specific annotation layer to 
make sure you are emailing only the areas you just annotated.)
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c.	 If you want to delete the rectangle annotations after sending the email, select Delete Annotation Layer 
After Snapshot Mailed.

6.	 Click Mail.

Receiving a Snapshot Email

The person receiving the ImageScope snapshot email sees the text you entered and attachments in .jpg format of the 
full ImageScope screen image and any annotations you selected for the email. The snapshot images are extracted at the 
same resolution used when the annotation was made. Note that the body of the message gives the names of the attached 
extracted regions, their resolution, and their size. 

Extracting a Region
You can extract selected regions of an eSlide in different formats and open the extracted region in another application. 
When you extract a region, you can define the exact size of the new image or use a predefined fixed size, which can be 
useful when preparing images for presentations or publication (see“Saving an Image of a Specific Size” on page 82 ).

Using the Extraction Tool

To extract a region:

1.	 Click  on the toolbar.

2.	 Place your cursor on the eSlide.
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3.	 Click and drag a rectangle on the screen to capture the area:

When you release the mouse button, the following displays:

4.	 Select among the following options:

Option Description
Output File Location where you want the extracted region file to be saved and name to be used. If you do 

not use the Output File button, the new file is created in the same location as the original eSlide 
and with the same name but with a number appended to it. For example, if the original eSlide 
file name is vs025_40Xn.svs, the extracted region is named vs025_40Xn_001.svs. (If a _001 file 
already exists, the extracted region file name ends in _002. If a _002 file already exists, the new 
file name ends in _003, and so on.)

Description Your title for the extracted region.
Left Left pixel co-ordinate of the original image.
Top Top pixel co-ordinate of the original image.
Width Width of the extracted image in pixels.
Height Height of the extracted image in pixels.
Thumbnail Attach the thumbnail of the exported image.
Label Attach the label image from the original scan if it exists.
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Option Description
Macro Attach the macro image from the original if it exists.
Tile Size Determines the organization of the data within the extracted image. For large SVS and TIFF files, 

a tile size of 240 or 256 is optimal to enable fast access to the image. 

To extract images for use with a third-party program that doesn’t support blocked TIFF files, you 
can set the tile size to zero to create a “stripped” image. Stripped TIFF files are supported by all 
software that processes TIFF files, but there is a performance penalty for large images (it does 
not affect small images). JPEG files are always stripped (tile size is always zero).

Output/ 
Compression

The different file formats you can select for the saved image and their compression options:

yy SVS file format using JPEG2000 or JPEG compression
yy JP2 file format using JPEG2000 compression
yy TIF file format using LZW or no compression
yy JPG file format using JPEG compression
yy CWS file format using JPEG compression

Nx16 to 3x8 If you are using an Aperio fluorescent image (Aperio Fused Image, .afi file), this check box 
appears. Selecting this check box tells ImageScope to create a single 3-channel, 8-bit RGB 
image file in the file format you selected. See “Note on Fluorescent Images” below for more 
information.

ICC Profile If an ICC profile is embedded in this image, you can select how it will be managed in the 
extracted image (embedded, applied, ignored). For information on Aperio ePathology color 
management, see “Appendix B: Aperio Integrated Color Management” on page 136.

5.	 Choose the options you require and click Extract. A progress bar shows the status of the extraction. When the 
extraction is complete, additional buttons are available for viewing the image:

6.	 Click View to open the extracted image in ImageScope. (For information on the Launch button, see “Compatibility 
Notes” on page 83.)  

Note on Fluorescent Images

Multi-channel eSlides produced by the Aperio FL consist of two or more 10-bit monochrome images in the .svs file 
format (one for each fluorochrome on the slide), as well as a composite file (.afi, for Aperio Fused Image). When you use 
the extraction, conversion, and compression features in ImageScope on multi-channel images, you obtain individual 
monochrome images plus a new .afi file of the size and file format selected during the process. Extracted monochrome 
channel images have the original pseudo-color enabled by default when opened in ImageScope.
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If you are creating the extracted files in the same directory as the input files, ImageScope creates a unique file name for 
the new files. (For example, if the original files are 223.afi, 223_DAPI.svs, and so on, ImageScope creates new files named 
223_001.afi, 223_DAPI_001.svs, and so on.) Make sure the channel .svs files are in the same directory as the .afi file 
because the .afi file references them.

ImageScope allows you to create a single 8-bit RGB file from the channel images, which can be useful for sending an image 
for publication. To do this, use the Nx16 to 3x8 check box at the bottom right. The label of this check box differs depending 
on the characteristics of the channel files that make up the image. For example, if your original slide used four fluorescent 
dyes (and therefore four .svs files were created by the scan), the label will say 4x16 to 3x8. (By default, Aperio fluorescent 
images are 10 bit, but the files are saved using 16 bits.) 3 x 8 refers to the output format, a three-channel, 8-bit RGB file.

If this check box is not selected (default), the image extraction results in new monochrome files. If the check box is selected, 
ImageScope converts the channel images to a single RGB file (in the format you selected in the Output/Compression area of 
the window).

Color Management Options

When you extract a region from ImageScope, you can specify one of the following:

`` Embed – The scanner’s ICC profile is embedded in the image.

`` Apply – The image is transformed using the monitor ICC profile.

`` Ignore – No color management is done.

Saving an Image of a Specific Size

To create an image of a specific size:

1.	 Follow the steps above to capture the area you want to extract.

2.	 When the Extract Image Region window displays, adjust the size of the saved file by changing the settings in the 
Width and Height boxes.
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Tips:

`` The first column of numbers after Width and Height is the number of pixels of the original extracted image. The 
second column is the output dimensions, initially set the same as the original values. 

`` The percentages show the ratio between the original dimensions and the output dimensions. The check mark in 
the box causes both the width and height to be adjusted proportionally (thus preventing the image from being 
distorted). You will usually want to keep the box checked.

`` You can change the percentages to make an image smaller. If you are extracting a number of images, using the 
same percentage for them all ensures they all have the same resolution. You can also adjust the percentage to 
greater than 100 to make the image larger.

`` Instead of changing the percentages, you can define a specific output dimension by typing the exact number of 
pixels you want for the height and width in the second width and height columns.

Extracting an Image of a Predefined Size or Aspect Ratio

If you have predefined a fixed size (see “Fixed Size Annotations” on page 128), to extract an image in the predefined size, 
hold down the Ctrl key while you click the extract tool  on the toolbar.

To extract an image using the same aspect ratio of the predefined size (but not necessarily the same size), hold down the 
Shift and Ctrl keys while you use the extract tool to draw the region to extract.

Managing Viewing Applications

You can define applications other than ImageScope for viewing extracted regions. Doing so defines what viewing 
application ImageScope launches from the Extract Image Region window, but you can also open the extracted file outside of 
ImageScope using any compatible image viewing software (see the next section).

Compatibility Notes

Be aware that the viewing application you define may not be able to open an image of the type you’ve extracted. For 
example, Internet Explorer cannot open TIFF files, but can open JPEG files. If you click Launch and the application cannot 
open the extracted file, an error message appears from the application indicating it cannot open this type of file.

Also, the viewing application you define may not be able to handle a file as large as your extracted file. Some applications 
have a limit on the size of file they can open and work with.

Some third-party programs cannot handle TIFF files, which use any form of compression. When in doubt, you can specify 
None for compression of TIFF files. However, if the region is large, using no compression results in a very large file. 
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Defining a Viewing Application

To define a viewing application:

1.	 Follow the instructions above to capture and extract a region of an eSlide.

2.	 Click the drop-down box next to the Launch button and select Define Application. 

If no applications are defined, this list is empty except for this selection. If applications are defined, they display in 
alphabetical order.

The following window appears:

3.	 Type a description of the application (for example, Photoshop) in the Application Name text box. This can be 
any text you want to use.

4.	 Click Browse to navigate to the location of the application executable file and select that file.

5.	 Click Add to add this application to the list of ImageScope viewing applications.

6.	 Click Done. 

Using the Viewing Application

To view an extracted region with a viewing application (after one is defined):

1.	 Follow the steps above to extract a region.

2.	 Click the drop-down box next to the Launch button and select a viewing application.

3.	 Click the Launch button. (If no applications are defined, the Launch button is disabled.)
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Deleting Viewing Applications

To delete applications previously defined:

1.	 Follow the steps above to extract a region.

2.	 Click the drop-down box next to the Launch button and select Define Application.  

The following window appears:

3.	 Click the Application Name drop-down box and select the application you want to delete from the list of 
ImageScope viewing applications. The Add button now changes to a Delete button.

4.	 Click Delete to delete the application from the list of ImageScope viewing applications. (This does not delete the 
application from your disk, but only from the list of ImageScope viewing applications.)

5.	 Click Done.
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This chapter discusses how to use algorithms to analyze eSlides. We discuss the general-purpose analysis 
procedure that uses the Annotations detail View. For information on streamlined eIHC analysis, see 
“Annotations Summary View Window – Quick eIHC Analysis” on page 58.

Analyzing eSlides helps you to examine the slide staining to find any unusual patterns. Using an algorithm to look for these 
patterns provides precise, quantitative data that is accurate and repeatable.

About Analyzing eSlides
There are three different types of analyses you can perform on eSlides:

`` Use ImageScope to analyze a single, remote eSlide that resides on eSlide Manager. The analysis results are stored 
remotely with the image in the Aperio ePathology database.

`` Use eSlide Manager to analyze a single eSlide or a batch of eSlides that reside on eSlide Manager. Results are 
stored in the Aperio ePathology database. For information on submitting batch jobs to analyze groups of eSlides, 
see the eSlide Manager Operator’s Guide.

`` Use ImageScope to analyze a single, local eSlide that resides on your workstation or network location accessible 
by Microsoft file sharing. The algorithm analysis results are stored locally with the image as annotations.

The ImageScope user interface is different depending on whether you are analyzing a local or a remote image. 
See“Analyzing an eSlide in eSlide Manager” on page 87 and “Analyzing a Local eSlide” on page 91.

Note that before you can analyze an eSlide on eSlide Manager, an eSlide Manager administrator must fine-tune the 
algorithm parameters and save the settings as a macro. See “Chapter 15: Registering Algorithm Macros on eSlide 
Manager” on page 97.  

Partial or Full Analysis

You can analyze an entire eSlide image or you can use the annotation tools to choose an area to analyze. You can also draw 
an annotation that excludes an area from analysis.

Results from the Analysis

You can save algorithm analysis results as a visual “markup image” and also as quantitative data that can be exported to 
be read by a spreadsheet program. The analysis results can also display in eSlide Manager if slide-specific processing is 
set up. In all cases, the original eSlide image is never modified. Rather, a new annotation layer with the markup image and 
quantitative data is created and linked to the image.
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Algorithms
The process of analyzing an eSlide is done by applying algorithms directly to the eSlide or selected regions of the eSlide.

Algorithms are available for a fee from Leica Biosystems Imaging. Algorithms developed by third parties and tools for 
creating your own algorithms are also available. Contact Leica Biosystems Imaging for details.

Algorithms all have control parameters—for example, intensity and hue settings—that allow the algorithm to be tailored to 
your specific needs. See the algorithm documentation for information on specific algorithms.

For general information on using Aperio ePathology algorithms, see the Aperio Image Analysis User’s Guide.

Analyzing an eSlide in eSlide Manager  
When you open an eSlide in eSlide Manager, the analysis runs on eSlide Manager, allowing you to do other things on your 
workstation. The results of the analysis are stored in eSlide Manager as an annotation layer of the eSlide.

Incremental Analysis

Some Aperio ePathology algorithms support incremental processing. Incremental processing allows the algorithm to analyze 
only regions added after the initial analysis without re-analyzing the previously analyzed regions. This can save a great deal 
of time and is useful when a pathologist draws a single region and analyzes it, and after reviewing the analysis results 
wants to select additional regions and analyze them as well. The pathologist can add more annotation regions as needed or 
delete annotation regions and the analysis results will be updated accordingly.

If you delete a region, ImageScope automatically re-runs the analysis to update the summary analysis results. However, 
adding regions may make the analysis results incorrect until you re-run the analysis.

Opening a Remote eSlide

Log into eSlide Manager and select and open an eSlide in ImageScope. See “Opening an eSlide on eSlide Manager” on 
page 15  for instructions.

Selecting an Area of the eSlide to Analyze

Only the rectangle and free-form pen tools can be used to draw annotation regions to include in 
analysis. Only the free-form negative pen tool can be used to draw annotation regions to exclude from 
analysis.

If you want to analyze only part of the eSlide, use the pen or rectangle drawing tool to select the area to analyze, or use the 
negative pen to exclude an area from analysis. (See “Chapter 9: Annotating eSlides” on page 55  for details on the 
drawing tools.) If you do not draw areas to include or exclude from analysis, ImageScope analyzes the entire eSlide. 

Here is an example of an area of analysis drawn by using the free-form pen tool:
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Performing the Analysis

To analyze the eSlide:

1.	 Go to the View menu and select Analysis. Specify the algorithm macro to run. 

The list you see depends on which algorithm macros are installed on eSlide Manager. If you do not see any 
algorithms listed or do not see the one you want to use, see “Chapter 15: Registering Algorithm Macros on 
eSlide Manager” on page 97 for information on creating macros. 
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The features of the Algorithm Server Job window make it easy to find the algorithm macro you want to use: see 
“Finding an Algorithm Macro” on page 90.

To create a macro on eSlide Manager, you must be logged in as an eSlide Manager administrator—if you are, the 
Test and Create buttons on this window are enabled.

2.	 Select the algorithm you want to use. If you want to create a visual representation of the analysis as well as a 
quantitative one, select the Generate Markup Image check box.

3.	 If this algorithm supports incremental processing, you can select the Incremental Processing check box to use 
that feature (see“Incremental Analysis” on page 87).  If the check box is not enabled, this feature is not available 
with this algorithm.

4.	 Click Analyze to start the analysis. A progress bar in the filmstrip shows the status of the analysis. 

You can also check the status of the analysis by going to eSlide Manager and using the Analysis > Jobs 
command.

5.	 Open the Annotations window to see the quantitative results of the analysis, which are listed under the layer 
containing the annotations that define the area of analysis. Note that the quantitative results are color-coded to 
match the mark-up image. (See “Algorithm Analysis Results” on page 95 for more information.)

If you selected the Generate Markup Image check box on the Algorithm 
Server Job window, the ImageScope main window also shows a visual 
representation of the analysis:
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Saving Analysis Results

Both visual and quantitative results from a remote analysis are stored in the eSlide Manager database linked to the eSlide.

To save the quantitative results in a plain text form that can be imported into a spreadsheet program, click  on either the 
Layer Attributes pane to export the combined results for all annotation regions on the selected layer or the Layer Regions 
pane to export the results in text format for each annotation region.

Or, click the  icon on the Layer Attributes or Layer Regions pane to save the data as an Excel spreadsheet. Numeric data 
exported to a spreadsheet is exported as text. Excel shows a warning note for each of these cells that the numbers are in 
text format—when you click on the note you can select an option to transform the text to numeric format.

See “Algorithm Analysis Results” on page 95 for more information. 

Finding an Algorithm Macro
When selecting an algorithm macro to use, the Algorithm Server Job window organizes the macros so that it is easy to find 
the one you want. 

`` The All Macros tab lists all of the macros available on eSlide Manager that you have permission to use.

`` The My Macros tab lists all of the macros that you have created.

`` The Project Macros tab lists the macros associated with projects. This tab is used by operators who log into the 
Research data hierarchy.

`` Sort the macros by clicking on the column title of the column you want to sort on. For example, to sort the macros 
alphabetically by name, click on the Macro Name column title.

`` When you have a large number of macros, use the Prev and Next buttons and the page number drop-down list to 
navigate through the list.

`` To search for a specific macro, select the tab you want to use and type characters in the macro name in the Search 
by name box—as you type, you see macros listed that have those characters in their name.
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Analyzing a Local eSlide 
1.	 Open an eSlide you want to analyze on your workstation or local network. (See“Chapter 3: Opening an eSlide” 

on page 14.)

2.	 If you are going to analyze only a portion of the eSlide, use the rectangle or free-form pen annotation drawing tools 
to:

yy Select one or more areas to analyze; or

yy Select one or more areas to exclude from the analysis.

(See “Chapter 9: Annotating eSlides” on page 55 for information on using the annotation tools.)

3.	 Go to the View menu and select Analysis. The following window displays:

The last algorithm that was used is displayed in the Algorithms window. 

Note that this window differs from the algorithm parameter window shown when you create an algorithm macro for an 
eSlide opened from eSlide Manager—the Outputs button is disabled as you are not saving data on eSlide Manager and so 
do not need to specify which outputs to export to eSlide Manager. And the Save Macro button is disabled as you cannot 
save the macro to eSlide Manager.

On this window you can:

`` Select another algorithm to use

`` Select whether to analyze the entire eSlide, just the portion of the eSlide on the ImageScope main window, or just 
a selected annotation.

`` Import or export algorithm settings from or to your workstation.
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`` Modify algorithm settings

`` Select whether to show the analysis results visually (markup image) as well as quantitatively.

`` Select the Analysis radio button and click Run to run the analysis using the current parameter settings.

`` Select the Tuning radio button and click Run to open a tuning window to see instant feedback on parameter 
changes. See “Using the Tuning Window to Test Algorithm Parameters” on page 103.

Selecting an Algorithm

If you want to use an algorithm other than the one displayed in the Algorithms window, click Select Algorithm. The 
following window displays:

Any algorithms you have purchased and installed appear in this window. Select the algorithm you want to use and click 
Select. Note that the macros you create work only with the version of the algorithm used to create it. For example, if you 
previously created a macro to work with version 8.1 of the Positive Pixel Count Algorithm, an error message appears if you 
try to use it with version 9 of the Positive Pixel Count Algorithm. 

Selecting the Region of Analysis

You can choose to analyze:

`` Current Screen – Analyzes just the portion of the eSlide on the ImageScope main window at the current zoom 
level. This is useful for testing the behavior of an algorithm and fine-tuning the algorithm parameters.

`` Entire Image – Analyzes the entire eSlide. This can take a long time to complete depending on the size and 
complexity of the image.

`` Selected Annotation Layer – Analyzes one or more annotations on the selected annotation layer or excludes 
from analysis one or more annotations (if they were drawn using the negative pen tool). Open the Annotations 
window and make sure the annotation layer containing the areas you have drawn is selected. (See “Chapter 10: 
Using the Annotations Window” on page 58 for information on annotation layers and the Annotations window.)

Modifying Algorithm Parameters

You can modify algorithm parameters to fine-tune the algorithm for your needs. Click a parameter listed on the Algorithms 
window. If you can modify it, you either see:
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`` The edit icon . Type a new value into the field or click 
the edit icon to select a new value using a slider control:

`` A down arrow, which means you can select from the drop-
down list:

For information on the parameters for a specific algorithm, refer to the documentation that accompanies that algorithm.

Enabling Data Plots
When you are creating a macro for an algorithm that supports data 
plots, unless that algorithm enables plots by default, you will need to 
select plots in the algorithm input parameters, as shown here.

Depending on the algorithm, once plots are enabled, you may also be 
able to select details about the plots. For example, in this algorithm 
parameters list you can specify the beginning and end values of the 
different plots:
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Importing/Exporting Macros

Once you fine-tune the algorithm parameters, you can save the algorithm and its changed parameters to use in the future. 
(The algorithm + modified parameters is known as a macro.)

1.	 Click Export Macro. 

2.	 On the File Save window, type a descriptive file name in File name and click Save.

To import a previously saved macro, click Import Macro and select the macro file from the file selection window.

(To register the saved macro on eSlide Manager log into eSlide Manager as an administrator and use the Analysis > 

Macros > Add command. See the eSlide Manager Administrator’s Guide for details.)

Running the Analysis

You can use the Tuning radio button to open a window that shows instant feedback on parameter 
changes. See “Using the Tuning Window to Test Algorithm Parameters” on page 103 for details.

1.	 Go to the View menu and select Annotations. This opens the Annotations window where the quantitative portion 
of the analysis results are displayed. 

If you drew annotations to include or exclude regions from the analysis, click on the annotation layer containing the 
annotations in the Annotations window to make sure the correct annotation layer is selected.

2.	 To view a visual representation of the analysis results on the eSlide image, select the Generate Markup Image 
check box.

3.	 Click Run. As the analysis proceeds, you see status information appears in the Algorithms window:
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Algorithm Analysis Results
When the analysis is done, the Algorithms window displays “Analysis complete.” If you analyzed this slide locally, the 
results are not saved in eSlide Manager, but are saved in an annotations file where the local file resides. A new annotation 
layer displays in the Annotations window which contains the quantitative results of the analysis, as shown below.

The results for each annotation region are listed in the Layer Regions pane. The combined results for all annotation regions 
are listed in the Layer Attributes pane.

To save these results in a plain text form:

1.	 Click  on either the Layer Attributes pane (to export the combined results) or the Layer Regions pane (to export 
the results for each annotation region).

2.	 On the file save window, type a descriptive name in the File name text box and click Save.

Or, click the  icon on the Layer Attributes or Layer Regions pane to save the data as an Excel spreadsheet. Numeric data 
exported to a spreadsheet is exported as text. Excel shows a warning note for each of these cells that the numbers are in 
text format—when you click on the note you can select an option to transform the text to numeric format.

Viewing Result Plots in ImageScope

If the Annotations window is in summary view, and you run an analysis using an algorithm macro 
in which data plots are enabled, all data plots automatically open in individual windows when the 
analysis is complete.

After you run an algorithm for which plots are enabled, to see the resulting plots, go to the View menu in ImageScope and 
select Annotations.

On the Annotations window in detailed view, click the Plots icon, .
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If you do not see the Plots icon, make sure the Annotations window is in detailed view, and not summary view. (If you only 
see summary view and there is no Details button to return to detailed view, you are in clinical viewing mode—go to the 
View menu and select View Standard Toolbar.)

After clicking the Plots icon, a plot window opens containing links to the plots available for viewing. 

Click a link to see that histogram. The window displays for that plot. You can re-size this window by grabbing a corner of it 
and dragging.

Note the icons on this window:

Click to see the definition of each colored curve.

Set up printer so that you can print the plot. This opens the standard dialog 
window for your printer so you can choose paper size and other printer 
options.

Print the plot.

Make the plot window transparent so you can see the eSlide image through it.

Restore window to original size.
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Macros on eSlide Manager

This chapter discusses how to create and save an algorithm macro on eSlide Manager. You must be logged 
into as an administrator to perform this procedure.

Before you can use an algorithm to analyze an eSlide in eSlide Manager, a macro (an algorithm’s settings) must first be 
registered on eSlide Manager. 

To create an algorithm macro, you need to install the algorithm on both your local workstation and on eSlide Manager. This 
consists of simply running the algorithm installer on both computers.

Creating and Saving a Macro
To create a macro, you will:

1.	 Open an eSlide in ImageScope from eSlide Manager.

2.	 Select an Algorithm from which to make a macro.

3.	 Create the macro.

4.	 Save the macro on eSlide Manager.

Open an eSlide

To open an eSlide in eSlide Manager:

1.	 Log into eSlide Manager as an administrator.

2.	 Use the eSlide Manager List commands to see the eSlides on your site or use the search feature.

3.	 Select the eSlide you want to use and click View Images to open the image in ImageScope.

The eSlide opens in ImageScope.

Create a Macro

The Test and Create buttons are disabled if you are not logged in as an eSlide Manager administrator , 
because only administrators can create and modify algorithm macros.

The Analyze button is disabled if your user permissions are not set to Full Control for the data group 
containing the eSlide image.
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1.	 Go to the ImageScope View menu and select Analysis or type Ctrl+G.

2.	 From the Algorithm Server Job window, click Create. The Select an Algorithm window displays:

3.	 Click the algorithm you want to create a macro for and click Select. 
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This loads the algorithm macro with its default parameters so you can see its unmodified parameters. 

4.	 Modify the Input parameters to suit your application.

Click a parameter listed on the Algorithms window. Parameters that you can modify either have an edit icon  or 
a down arrow next to them. Do one of the following:

`` Click the edit icon . Type a new value into the field or click the edit icon to select a new value using a slider 
control:
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`` Click the down arrow to select from the list:

For information on the parameters for a particular algorithm, refer to the documentation that accompanies that 
algorithm.

When you are creating a macro for an algorithm that supports data plots, unless that algorithm enables plots by 
default, you need to select plots in the algorithm input parameters. For example:

For information on viewing result plots, see the previous chapter.

The Classifier Neighborhood, Classifier, and Class List parameters are only used if you are using Genie classifiers 
with this algorithm. Your eSlide Manager administrator can tell you if Genie classifiers are available on your eSlide 
Manager site. (Genie is a histology pattern recognition tool that works with Aperio ePathology algorithms to 
automatically identify tissue types for analysis. For more information, see the Genie User’s Guide.)
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5.	 Click Outputs to select the results display in eSlide Manager. (If you are analyzing a local slide, the Outputs button 
is disabled as the results are not sent to eSlide Manager.)

Clear the check boxes next to the results you don’t want to display in eSlide Manager.

6.	 Click Run to test the algorithm on the eSlide. You can see the results in the ImageScope Annotations window, and 
in the mark-up images in the ImageScope window.

You can click the Tuning radio button to open a tuning window in which you can see 
instant feedback on parameter changes. See “Using the Tuning Window to Test Algorithm 
Parameters” on page 103 for details.

7.	 When you are satisfied with the results, save the macro on eSlide Manager.
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Save the Macro on eSlide Manager

After you have created the macro, saving the macro registers it on eSlide Manager.

1.	 On the Analysis window, click Save Macro to save the macro and register it on eSlide Manager:

2.	 Enter a name for the macro and click OK.

Select the data group you want to associate with the macro. A message displays that the macro is saved. It is now 
registered on eSlide Manager.

Testing and Modifying an Existing Macro
The Test button modifies and tests an existing macro before saving to eSlide Manager. 

1.	 Open an eSlide on eSlide Manager.

2.	 Go to the View menu and select Analysis or type Ctrl+G.

3.	 Select a macro from the Algorithm Server Job window and click Test.

This loads the algorithm macro with its existing parameters. 
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4.	 Modify the parameters as discussed in the previous section, select the Analysis radio button and click Run to test 
the macro on the eSlide or select the Tuning radio button and click Run to see immediate feedback on parameter 
changes (see the next section for details).

5.	 On the Analysis window, click Save Macro to save and register the macro on eSlide Manager.

6.	 Enter a name for the macro and click OK. 

Using the Tuning Window to Test Algorithm Parameters
The purpose of the algorithm tuning window is to provide a way to quickly view the results of analyzing a different area of 
an image or to test changes to the algorithm parameters.

These instructions discuss using the tuning window when opening an image from eSlide 
Manager. You can also use the algorithm tuning window when you open a local image—in 
this case, analysis results are saved locally, not in the eSlide Manager database. For details 
on analyzing local images, see “Chapter 14: Analyzing eSlides” on page 86.

To use the algorithm tuning window:

1.	 In eSlide Manager, open an eSlide in ImageScope.

2.	 In ImageScope, go to the View menu and select Annotations to open the Annotations window. This window is 
where your numeric algorithm analysis results display.

3.	 Go to the View menu and select Analysis. 
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You see the Algorithm Server Job where you can select the algorithm macro you want to use.

The features of the Algorithm Server Job window make it easy to find the algorithm macro you want to use, see  
“Finding an Algorithm Macro” on page 90.

4.	 Select the macro you want to use and click Test. You see the algorithm parameter window.

5.	 On the algorithm parameter window, select the Tuning radio button and click Run. On the ImageScope main 
window, you see a new Algorithm Tuning window with the mark-up image from the analysis using the current 
parameters.
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Click the eye icon to turn the mark-up display on or off. To adjust the size of the Algorithm Tuning window, drag a 
corner to change the window size.

You see the numeric results of the analysis in the Annotations window Tuning Layer: 

Every time the Algorithm Tuning window updates the analysis, a new mark-up image appears and the numeric data 
in the Annotations window changes to reflect the new analysis.

`` To see the analysis of another area of the eSlide, drag the Algorithm Tuning window to another area or move 
the eSlide under the window.

`` To see the results of the analysis when you change the parameters, simply change the parameters in the 
algorithm parameters window and the tuning window updates.

Note on the Algorithm Tuning Window

The purpose of the algorithm tuning window is to provide a way to quickly view the results of analyzing a different area 
of an image or to test changes to the algorithm parameters. If you are viewing the eSlide in ImageScope at the same 
magnification as the one used to create the eSlide (for example, you scanned the glass slide at 20x and you are viewing the 
resulting eSlide at 20x), then the tuning window provides the same results as running the algorithm on the selected area. If 
you are viewing the eSlide at a different magnification than its original scan magnification, the tuning window results may 
differ slightly from those obtained by running the algorithm on the same area.
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eSlide conferencing makes it possible for several participants to view the same eSlide from multiple, 
remote locations. This section discusses how to use the eSlide conferencing feature of ImageScope. 

About eSlide Conferencing
ImageScope eSlide conferencing not only allows multiple people to view the same eSlide at the same time, but also 
provides the following features:

`` Synchronized viewing so all participants see the same region of the eSlide at the same time

`` Real-time annotation sharing

`` Leader/follower roles and the ability to change those roles

All conference participants must have ImageScope installed on their workstations. (Download the latest free ImageScope 
software from www.LeicaBiosystems.com/ePathology.)

Concepts

`` The person hosting the conference is called the leader. This is usually the person who created the conference. 

`` Participants who join the conference are called followers. Followers can see the eSlide the leader opens on the 
ImageScope viewer along with any annotations the leader makes.

`` Conferencing requires that all parties have access to a common DSC server and a common ImageServer or network 
share where images are stored.

http://www.aperio.com
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Starting an eSlide Conference
1.	 Log into eSlide Manager and open an eSlide.

2.	 Go to the View menu and click Digital Slide Conferencing. The following window displays: 

Connecting to an eSlide Conferencing Server

1.	 On the Digital Slide Conferencing window, click DSC Server. The following window appears: 

2.	 Type the following information:

yy Server Name – The example shows a DSC server running at dsc.scanscope.com. Type the name of the server 
that is running the DSC service on your network. Usually this is on your DSR, a dedicated server, or it may be 
on your workstation.

yy Port – Type the number of the port that has been configured for DSC. This is usually 80, but can be set to 
another port.

yy Email Address and Password are not required. 
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yy Screen Name – Type the name you want to use as the leader of the conference. You are identified by this 
name in the conference participant list.

3.	 Click Login. The status changes to Connected and the Create Conference button is enabled.

If you set up the DSC server on your workstation, verify your workstation is accessible to 
others. See your network administrator if necessary to ensure the correct ports are open, 
firewall permissions are set appropriately.

 Creating a Conference
1.	 Click the Create Conference button, and then enter the name of your conference:

2.	 Enter any name you wish and click OK. 

You are notified that you are the conference leader. The baton next to your name  indicates that you are the 
conference leader.

 	

3.	 To display your mouse cursor in the participants’ view, select the Show Mouse check box.

The conference is now created.

Opening an Image to Share

The conference leader may open one or more eSlides to share in the conference. Because all participants must have access 
to the images too, the leader must open images on an ImageServer using the Access Remote Server command or directly 
from eSlide Manager. (You cannot share images in an eSlide conference if they are only on your workstation.)
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The leader can open and move between multiple images during the conference using the 
ImageScope filmstrip.

Joining a Conference

Once a conference is created, participants may join.

1.	 Log into eSlide Manager and open any eSlide by clicking an eSlide thumbnail on the eSlide Manager page. 

2.	 Follow the instructions in “Connecting to an eSlide Conferencing Server” on page 107  to connect to the DSC 
server. The following window displays listing any conferences running on that server:

Type the screen name you want to display to the other conference participants.
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3.	 In the Conferences section, select the conference you want to join and click Join Conference. The Digital Slide 
Conferencing window displays, listing you as a participant:

In the ImageScope window you now see the eSlide the conference leader has opened to share.

Viewing Slides in Conference
The conference leader is in charge of the conference:

`` As the leader zooms and pans the eSlide, the participant’s view matches the view of the leader. The leader’s mouse 
position is visible as a pointer on each participant’s monitor if the leader selected the Show Mouse check box.

`` Each participant may have a different screen size or window layout. Each window is kept centered following the 
leader’s actions, but the image is adapted to the participant’s window configuration and monitor resolution.

`` Only the leader can add annotations, which are visible to all participants.

Changing the Conference Leader
There may be times when either the leader or one of the followers wishes to change the conference leader. For example, 
one of the followers may want to point to something on the eSlide or the leader may leave the conference before it is 
finished.

If the leader of the conference exits the conference before it is finished, the next person who 
joined automatically becomes the leader.

When conference leadership changes, a message appears to alert the participants.

Leader Initiates Change in Leadership

If the leader wishes to assign leadership to another participant, select a follower in the list of participants and click Assign. 
The new leader receives the message that leadership has changed.
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Follower Initiates Change in Leadership

If a follower wants to become the conference leader:

1.	 On the Digital Slide Conferencing window, select the Request check box. 

 

The DSC server maintains a list of all participants who want to become the leader. An hourglass displays next to 
the names of followers waiting to become the leader.

2.	 To assign the leadership to the next waiting participant, click Relinquish.

 

The requester is notified that he or she has leadership.

Conference Creator Re-asserts Leadership 

If the person who created the conference wants to become leader again, on the Digital Slide Conference window, click 
Grab.  
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TelePath Live, also known as Remote Revisit, provides a way to connect to your scanner remotely. 

By using TelePath Live to directly connect to your scanner, you can:

`` View a live video feed from the scanner from a remote location.

`` Capture Z-stacks and view specimens in multiple focal planes.

`` Perform a scan directly from ImageScope.

Scanner Compatibility Notes
`` For scanners that contain an AutoLoader—a slide must be on the slide tray to use the Z-stack feature. You cannot 

capture Z-stacks from slides in an AutoLoader.

`` Some older scanner models cannot use the TelePath Live feature; contact Leica Biosystems Imaging Technical 
Services if you have questions about whether your scanner can use TelePath Live.

`` Aperio CS scanners support TelePath Live from all five slide positions in the slide tray.

Before You Use TelePath Live
There are some things you should do and know before you use TelePath Live.

Calibration

Your scanner is calibrated at the factory. However, if while using TelePath Live you find that the Live window does not line 
up with your cursor position in the ImageScope main window, you should calibrate it again.

For information on calibrating the scanner in preparation for using TelePath Live, please see the TelePath Live (Remote 
Revisit) Setup Application Note.

Setting the ImageServerURL

In order for the Console program View Slide button to display images in ImageScope that can be used for TelePath Live, the 
ImageServerURL parameter needs to be set up with your ImageServer name. 

To set up ImageServerURL:

1.	 Start the scanner Console program by clicking Start > All Programs > ScanScope > Console.

2.	 Open the Configure window. (See your Console User’s Guide for specific instructions.)
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3.	 Click the ScanScope Properties tab.

4.	 In the Name field, type: ImageServerURL and click Get.

5.	 Verify that the name of your ImageServer displays in the Value field.

a.	 If the ImageServer name is correct, you are done. 

b.	 If the ImageServer name is not correct or is blank, type the correct name of the ImageServer into the Value 
box and click Update. 

6.	 Click Close to exit the Configure window. After you exit the Console, your change to ImageServerURL will take 
effect the next time you start the Console again.

Here is a little more information about why you need to set this parameter:

When ImageServerURL is set to a valid ImageServer machine name, ImageScope opens the eSlide by passing the 
imageID directly to ImageServer. ImageServer uses the database to locate the eSlide. You can tell that you are in the 
database mode if you see a number beginning with the @ symbol in the title bar of ImageScope. 

You must use ImageServer in this database mode to save captured Z-stacks into the database. If ImageServerURL is not 
set, Z-stacks your capture in ImageScope will not be saved in the database when you open the eSlide using the View 
Slide button in the Console.

What Is a Z-Stack?
A Z-stack is a three-dimensional image that allows you to view a specimen by moving up and down in the focal planes. This 
is especially useful for viewing “thick” specimens.

Z-stack images are cataloged in the ImageServer database, and linked to the original image as an annotation. One of the 
reasons for using the TelePath Live feature is to capture and view Z-stack images. See “Capturing Z-stacks” on page 117 
for more information.
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Connecting to an Aperio Scanner
1.	 Go to the ImageScope View menu and select TelePath Live. The following window displays:

2.	 Click Configure to define which scanner to connect to. The following window displays:

3.	 Type the name of the scanner and its port (usually 3333). 

4.	 Define the ImageServer by typing the host name and port number. If you are using an Aperio CS or T3 scanner, this 
is the same name and port number as your scanner.

Note that the name of your ImageServer host is typically the same as the ImageServerURL setting (see ”Setting the 
ImageServerURL” on page 112) unless you access the ImageServer from outside a firewall, in which case it may 
be different—contact your network administrator for assistance.

5.	 Click OK.

6.	 On the TelePath Live window, click Connect. 
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Troubleshooting Tips: If you are unable to connect to the scanner, contact your network 
administrator to verify the following conditions are true for your network:

yy Port 3333 is open and directed to the scanner controller.

yy Port 82 is open and directed to the ImageServer.

8.	 Log in using your eSlide Manager user name and password.

After a few seconds, a window appears showing slides that are loaded in the tray. You are now connected to a 
scanner.

The blue dot indicates the slide you are working on. You can click any displayed slide to select that slide.

If the window has no slides displayed, click the Refresh Snapshots button to load macro slide images. 
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Preparing a Slide for TelePath Live
There are two ways to prepare a slide for use with the TelePath Live window:

1.	 Scan a slide on the scanner and click the View Slide button in the Console. When ImageScope opens, you can 
begin placing Z-stack images on the eSlide from the ImageScope TelePath Live window.

2.	 Use the Revisit Quick Scan or Revisit Hi-Res Scan buttons on the ImageScope TelePath Live window. (See 
“Capturing Z-stacks” on page 117.)

Viewing Live Video from the Scanner
Connect to the scanner and open the ImageScope TelePath Live window as discussed in “Connecting to an Aperio Scanner” 
on page 114.

After a scan is performed, click around on an eSlide in the TelePath Live window and see a live video feed from the scanner 
showing the tissue in the Live window. 

When using TelePath Live, coarse and fine focus sliders provide fine-resolution focusing, allowing you to fine-tune the focus:

The right slider’s range is 10% of the entire focus range provided by the left slider, centered on the value of the left slider. 
For example, if the left slider is set at 50, the right slider’s range is 50 – 5% of the focus range to 50 + 5% of the focus 
range. 

Use the slider on the left to get the image roughly into focus. Then use the slider on the right to fine-tune the focus. 

`` Adjust the size of the Live window by using the Camera Mode drop-down list to select a window size:
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`` If you locate an area of interest, click the Capture Z-Stack button on the TelePath Live window to capture a 
Z-stack (3-dimensional) image of that area. (See the next section.)

Capturing Z-stacks
1.	 Open the TelePath Live window and connect to a scanner as discussed in “Connecting to an Aperio Scanner” on 

page 114.

The blue dot indicates the currently selected slide. Click on any other slide if you want to use it instead.

2.	 Select your Z-stack options:

`` Depth – The total number of microns in the Z-stack.
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`` Frame Count – The number of individual snapshots taken. The limit is 50.

`` Camera Mode – The width and height of the Z-stack snapshots. These are limited by the available modes of 
the area camera.

3.	 If you did not open ImageScope by clicking the View Slide button in the Console program, you may need to scan 
the slide:

`` Clicking the Revisit Quick Scan button on the TelePath Live window performs a high-resolution macro scan 
of the slide, generally used when time is short. The slide is scanned at 5x.

`` Clicking the Revisit Hi-Res Scan button on the TelePath Live window is the same as pressing the green 
button on the scanner. Only the currently selected slide is be scanned, and it is scanned at the currently 
selected magnification.

Whether the slide was scanned from the Console or from the TelePath Live window, when the slide is scanned 
its image displays in the ImageScope main window along with a Live window that shows the video feed from the 
scanner.

4.	 Click the image in the ImageScope main window. A yellow rectangle displays showing the area of the image 
displayed in the Live window. This also selects the area to perform a Z-stack capture. To move the selection 
rectangle, click another location in the main image.

5.	 To capture a Z-stack from the selected slide, click the Capture Z-Stack button. 
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When you see the message “Opening Z-stack” on the TelePath Live window, the Z-stack has been captured and a 
green rectangle displays overlaid on top of the yellow rectangle in the ImageScope main window. 

Click elsewhere in the image to move the yellow selection rectangle away from the Z-stack image. The green 
rectangle showing the location of the Z-stack.
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Viewing Z-stacks
Once you have captured a Z-stack image, you will see that the Live window now contains a coarse and fine focus tool:

To focus through the stack, simply slide the focus bar up and down.
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The utilities discussed in this section are primarily used for troubleshooting. Leica Biosystems Imaging 
Service representatives may ask you to use these utilities to pinpoint an issue.

Logging
If requested to do so by Leica Biosystems Imaging Services, enable logging by going to the Tools menu and selecting 
Logging. This creates a file named viewport.log where text messages on ImageScope actions are logged.

If you are having a problem, Technical Support typically asks you to:

1.	 Turn logging on.

2.	 Run until you encounter the problem again.

3.	 Then email Technical Support the viewport.log file. 

You should then turn logging off (by again going to the Tools menu and selecting Logging) as logging affects system 
performance.

Cache Display
Because eSlides are typically much larger than can be loaded into memory all at once, ImageScope keeps portions of the 
eSlide in computer memory so it can display them quickly. It prefetches data for the eSlide from disk or from a remote 
server, determining which portions of the image to fetch by anticipating where the user is going to go next. 

Enable the cache display by pressing the Shift+Ctrl+M keys. (Press Shift+Ctrl+M keys again to turn it off.)

The cache display shows which parts of the eSlide are loaded into ImageScope’s cache memory. The darker the area, the 
higher the resolution of the part of the image that is loaded.
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Below is an image of the ImageScope screen showing the cache displays:

Running Multiple ImageScopes
ImageScope normally allows only one instance of itself to run. (If ImageScope is open and you try to start it again, the 
first copy of ImageScope closes.) There may be special occasions when troubleshooting a problem or testing eSlide 
Conferencing, for example, when you want to run more than one copy of ImageScope at a time.

To run multiple copies of ImageScope:

1.	 Click Start and select Run.

2.	 Click Browse on the Browse window and navigate to the ImageScope.exe file on your workstation. (The default 
location is: C:\Program Files\ScanScope\ImageScope.)

3.	 Click Open.

The Run window now contains the path to the ImageScope.exe file.

4.	 At the end of the path specification, type a space and the characters /M (outside of the quotation marks) as shown 
below: 
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5.	 Click OK. One copy of ImageScope has now started. Repeat this procedure again to open a second copy of 
ImageScope.

Tuning Parameters/Statistics
To see how ImageScope is making use of memory and caching:

1.	 Go to the Tools menu and select Advanced. The following window displays:

Maximum Cache Size

`` Cache Limit – Limits the amount of memory that is allocated for image caching. If you set this to zero, then 
ImageScope will use up to 75% of your system’s memory as needed. You should typically leave this set to zero.  If 
you want to set the cache limit to a specific size, enter the number of megabytes. For example, 128 sets the cache 
limit to 128 megabytes. This is the only value on this screen that you can change (except for resetting the statistics 
to zero).

Statistics

The following fields change as you view and pan images. ImageScope only reports these values if an eSlide is open. You can 
reset them to zero by clicking Reset (unless noted otherwise below). 

`` Available Mem – Total amount of physical memory not in use on your system. The Reset button does not affect 
this value.

`` Total Mem – Total amount of memory installed on your system. The Reset button does not affect this value.
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`` Cache Max – Amount of cache memory used in megabytes.

`` Cache Used – Current amount of memory cache used in megabytes.

`` Cache Used HWM – High water mark for memory cache in megabytes.

`` Cache Buffers – Current number of buffers stored in cache.

`` Cache Buffers HWM – High water mark for buffers stored in cache.

`` Cache Searches – Number of cache searches.

`` Cache Hits – Ratio of cache hits to cache searches.

`` Cache Hits % – Ratio of cache hits to cache searches.
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Use the Options command to set and review ImageScope settings and preferences.

To access ImageScope’s settings, go to the Tools menu and select Options. The Options window appears. Click each tab to 
view or change the associated options.

General Options
The general options are organized into three areas: Magnification, Default Gamma Files, and Analysis.

Magnification

The magnification options are:

`` Initial Magnification – Specify the initial magnification for images as they are opened. This can be a percentage 
from 1 to 100 or you can specify 0 to fit the entire eSlide in the main window display.

`` Maximum Magnification – Specifies how far you can zoom into the image. Note that setting this value to 
greater than 100% does not increase the resolution of the image—it is enlarging the pixels of the existing image.

`` Magnifier Magnification – Specifies the ratio between the main window and the magnifier window. For 
instance, if this value is set to 3, and you are viewing the main image at 50% zoom, then the magnifier window 
displays 150% zoom. See “Using the Magnifier Window” on page 28 for information on the magnifier window.
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`` Use “X” magnification rather than “%” – Adjusts the Zoom slider from displaying magnification in percentages 
to displaying them as “2x,” 4x,” and so on. See “Zoom Slider” on page 28 for examples of the Zoom slider in 
both modes.

Default Gamma Files

Adjusting the display of an eSlide does not affect the original eSlide, but only its appearance during the current ImageScope 
session. You can save these adjustments in a gamma table file to be re-applied in a later session to one or more eSlides. 
(See “Saving and Loading Color Settings” on page 39 for information on creating gamma table files.)

The Default Gamma File sections on the General tab allow you to load specific gamma table files every time you start up 
ImageScope. This can be useful if you know you need to compensate for a particular monitor, for example (although a better 
long-term solution is to calibrate the monitor so it does not have a color bias).

Loading a Default Gamma Table File for the Main Image

To load a default gamma table file that is applied to all images opened in the main ImageScope window:

1.	 On the General tab, select the Automatically load default gamma file(s) check box.

2.	 Use the browse button in the Default Gamma File Location text box to search for the gamma table file you want 
to use. The Select default gamma file window appears.

3.	 To protect the selected gamma table file from being modified, select the Open as read-only check box on the 
Select default gamma file window.

4.	 Select the gamma table file you want to use and click Open.

Loading a Default Gamma Table File for Z-stack Images

To load the default gamma table file to be applied only to Z-stack images:

1.	 Select the Automatically load default gamma file(s) check box.

2.	 Use the browse button in the Default Gamma File Location – for Z-stack Images text box to search for the 
gamma table file you want to use.

3.	 To protect the selected gamma table file from being modified, select the Open as read-only check box.

4.	 Select the gamma table file you want to use and click Open.
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Analysis
When you run an algorithm to analyze an eSlide, you can request a visual representation of the analysis in addition to the 
quantitative data. (See “Chapter 14: Analyzing eSlides” on page 86 for more information.) This visual representation is 
called a markup image. 

`` To instruct ImageScope to always generate a markup image by default (this setting can be overridden when you 
perform the analysis), select the Generate Markup Images check box.

`` To specify the location of the markup file, click the browse button and navigate to the location where you want to 
store this data. (This location is used for analyses performed on local eSlides. Remote analyses store the markup 
image only in the eSlide Manager database.)

Navigation Options
The ImageScope navigation options affect image panning and multiple image synchronization.

Synchronization Option

When you have multiple eSlides open in ImageScope and they are all visible at the same time, you can click  or  
(yellow) on the toolbar to synchronize navigation among the open images. If the image navigation is synchronized and you 
pan or zoom the first image, the other images will show the same behavior. The synchronization option defines the behavior 
of that synchronization:

`` Both Pan & Zoom – Synchronizes both panning and zooming.

`` Pan Only – Synchronizes panning only.

`` Zoom Only – Synchronizes zooming only.
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Panning Options

The following panning options are available:

`` Scroll Speed – Specifies how fast the image scrolls when holding down the mouse button near the edge of an 
image.

`` Pan Speed –  Specifies how fast the image pans when clicking and dragging the image.

`` Reverse panning direction (“Pathologist” mode) – Select this check box to pan in reverse. With this option 
enabled, as you click and drag to the left, the image moves to the right.

Annotation Options
The Annotations tab of the Options window allows you to select annotation options.

Annotation Color Options

Each annotation layer displays annotations in a different color. The Default Annotation Colors section allows you to select 
the color used for each layer. 

1.	 Click the colored box above the annotation layer for which you want to change the color. 

2.	 From the color selection window, select a color from the palette shown or click Define Custom Colors to define 
your own color.

3.	 Click OK.

If you use more than five annotation layers, the new layers re-use the colors defined for the first five layers. For example, 
layer 6 will use the color defined for layer 1 and layer 7 will use the color defined for layer 2.

Fixed Size Annotations

The Fixed Size Regions options on the Annotations tab set a fixed size for drawn annotations that is used when you press 
the Ctrl key while you draw. These settings are also used to extract a region of fixed size and to zoom to a region of fixed 
size.
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`` Width and Height – these values define the size of rectangles or circles. For example, to always draw a square 
of 200 pixels by 200 pixels when you press the Ctrl key while using the Rectangle tool, type 200 into the Width and 
Height boxes.

`` Length – This value is used for the ruler and arrow annotations.

See “Report Image Options” on page 131 for information on setting the fixed size of a report image.

Automatically Saving Annotations

The Automatically Save Annotation Changes check box saves annotations and changes to annotations when you exit 
ImageScope without prompting for a confirmation. 

If this option is enabled, but you have also selected Don’t Save Recorded Tracks on the Tracking options tab, tracks will 
not be saved when you exit even though other annotations are. 

Tracking Options
The Tracking tab contains options that affect tracking. For example, you can enable tracking every time you open an eSlide 
in ImageScope. For information on tracking, see “Chapter 12: Tracking” on page 72.

The options on this tab include:

`` Automatically Start Tracking on Open – Always begin recording when you open an eSlide. If a track already 
exists for the eSlide, opening the slide starts appending a track to the original track.

`` Don’t Save Recorded Tracks – Disable saving the track with the eSlide.

`` Automatically Display Track Map – Enables track mapping by default. This also selects the Map check box on 
the Tracker tool.

`` Minimum Resolution – Specifies the minimum resolution of a view which is mapped. This defines the lowest 
resolution at which a region of the image is viewed.

`` Minimum Magnification – Specifies the minimum magnification of a view which is mapped. This defines the 
lowest magnification at which a region of the image is viewed.
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`` Region Granularity – Divides the image into granules when deciding which section of the image is glass and 
which is tissue. By changing the granularity, you affect the glass/tissue distinction. Slide the control to the left to 
decrease the granule size and to the right to increase granule size. Smaller granules generally mean that less of 
the image will be classified as glass, while larger granules mean more will be classified as glass. You can see its 
effect if a tracking map is shown in the thumbnail as you move this slider.

`` White Sensitivity – Displays your progress through tissue, not glass. This setting helps define which is tissue and 
which is glass. This slider adjusts the “whiteness” of detected glass. Dragging it to the left increases sensitivity, 
causing less of the slide to be classified as glass, and dragging it to the right decreases the sensitivity, causing 
more of the slide to be classified as glass. You can see its effect if a tracking map is shown in the thumbnail as you 
move this slider.

Performance Options
The Performance tab contains settings that allow you to balance display speed with image quality. These settings are 
provided because eSlides are usually too large to fit into memory all at once; therefore, some decisions have to be made 
about how ImageScope will act when swapping data in and out of memory from disk.

`` Progressive Rendering – When enabled, ImageScope renders image views in low resolution first, and then 
increasingly improves the image (by de-pixilating it) as it reads more image data from the disk or retrieves it from 
a remote server. With this feature disabled, ImageScope does not render an image view until the entire view has 
been loaded into memory.

`` Prefetching – When enabled, ImageScope anticipates your next view requests and loads those sections of the 
image into memory. By anticipating where you will move next in the image and loading that information into 
memory, ImageScope speeds up the image display.

`` Interpolating (3D images) – Displays a weighted average of the two neighboring Z-stack views for a Z-level.

`` Pixel Smoothing – Uses a high fidelity (but slower) scaling routine.
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HTTP Proxy Option
Some networks require that all HTTP traffic be routed through an HTTP proxy server. If you are using ImageScope inside a 
network that uses an HTTP proxy server, you need to define the proxy server to ImageScope.

Your network administrator can provide the settings you need for the server name, server port, user name, and password. 
Not all proxy servers require a user name and password.

If you have already created Windows proxy settings on your workstation, select the Use Windows Proxy Server Settings 
check box to use those settings.

Report Image Options
The Report Image tab allows you to select a combination of fixed or user selectable sizes and resolutions. The Fixed Region 
Size parameters define the size of the report image rectangle if you press the Ctrl key while selecting the image area.
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eSlide Manager Reporting is an optional upgrade that create attractive reports with a few clicks of 
the mouse. The report image feature is used with this product if you are using report templates that 
contain images.

Color Management Options
Aperio Integrated Color Management considers the optical characteristics of your scanner and your display monitor to 
ensure eSlide color is displayed accurately. For information on color management and ICC profiles, see “Appendix B: 
Aperio Integrated Color Management” on page 136. 

You can view the target monitor ICC profile or choose a new monitor:
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Email Settings
To use the ImageScope email snapshot feature, you must define email settings on the SMTP Server tab. The first time you 
use the email snapshot feature without these settings defined, ImageScope displays this tab. 

For information on how to email a snapshot of the eSlide displayed in ImageScope, see“Emailing a Snapshot” on page 77.

This window defines the information required for ImageScope to send email. For additional information about these settings, 
contact your IT department.

`` Server Name – Name of the server that hosts your email service.

`` Server Port – Port on your email server used to transfer email.

`` Use SSL – Select this check box if your email server uses SSL to secure email.

`` User ID/Password – If your email server requires authentication, then enter your user name and password.

`` eMail Address – Type the email address from which snapshots will be emailed

`` Send Test eMail – If you want to verify that the settings are correct, click Send Test eMail. A message displays 
if the test email was successful, and the person at the email address specified will receive an email titled “Test 
Email” that says “Successful!” 

For More Information
For more on ImageScope’s settings, see:

`` “Chapter 18: Utilities and Diagnostics” on page 121.
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A Keyboard Quick Reference

This section contains a quick reference list of keyboard shortcuts you can use with ImageScope.

ImageScope Keyboard Shortcuts

Key Sequence Command Toolbar 
Icon Action

Arrow key None Nudge image
Ctrl + Plus key None Zoom in
Ctrl + Minus key None Zoom out 
Ctrl Press while drawing an annotation to draw the annotation 

in a predefined size.
Ctrl+A Image > Adjustments Displays the Image Adjustments window where you can 

make image adjustments to the main image or to the 
Z-stack image, as well as load and save adjustments.

Ctrl+C None Enables/disables integrated color management
Ctrl+D View > Digital Slide 

Conferencing Window
Opens the Digital Slide Conferencing window where you 
can create or join an eSlide conference.

Ctrl+E Image > Rotate Image Opens image rotation toolbar
Ctrl+F None Turns image prefetching on/off.
Ctrl+F4 File > Close Image Closes the image currently open in ImageScope.

Ctrl+G View > Analysis Runs an algorithm analysis on a local or remote eSlide.
Ctrl+I Tools > Options > 

Performance
Turns interpolating on/off (used for viewing 3D images).

Ctrl+J Tools > Options > 
Performance

Turns progressive rendering on/off.

Ctrl+K Image > Keep Open Turns Keep Open option on/off.
Ctrl+L Tools > Logging Turns logging on/off.
Ctrl+M None Shows/hides track map
Ctrl+Shift+M None Shows/hides cache map.
Ctrl+N View > Annotations 

Window
Opens the Annotations window where you can work with 
annotation layers for the current image.

Ctrl+O File > Open Image Displays the Open Image window where you can browse for 
a local image file to open.
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Key Sequence Command Toolbar 
Icon Action

Ctrl+P Tools > Options Opens the Options window to set general, navigation, 
annotation, performance, and HTTP proxy options.

Ctrl+Q Image > Quality Turns IQ on/off.

Ctrl+R File > Access Remote 
Server

Connects to an Aperio ePathology ImageServer where you 
can select an image to view.

Ctrl+S Tools > Options > 
Performance

Turns pixel smoothing on/off.

Ctrl+Shift Moves all annotations.
Ctrl+T View > Thumbnail Shows/hides the thumbnail window.

F1 Help > Help Opens ImageScope help.

F2 None Pen drawing tool.

F3 None Negative pen drawing tool.

F4 None Ruler drawing tool.

F5 None Rectangle drawing tool.

F6 None Ellipsis drawing tool.

F7 None Arrow drawing tool.

F8 View > Annotation Link 
Manager

Opens the Annotation Link Manager window where you can 
link slide annotations in a specific viewing order.

F11 View > Full Screen View ImageScope on your entire monitor screen.

Shift None Press while drawing annotations: ellipse becomes a circle; 
rectangle becomes a square.

Shift+Arrow None Moves one screen at a time.
Shift+Ctrl None Press while drawing an annotation or using the extract 

region tool to create a region of the same aspect ratio as 
the predefined fixed annotation size.

Shift+F7 View > Previous 
Annotation Link

If annotation links have been set using the Annotation 
Link Manager, this moves to the previous annotation in the 
viewing sequence.

Shift+F8 View > Next Annotation 
Link

If annotation links have been set using the Annotation Link 
Manager, this moves to the next annotation in the viewing 
sequence.
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Management

Aperio Integrated Color Management considers the optical characteristics of your scanner and your 
display monitor to ensure the colors of the eSlides are displayed accurately.

A challenge for any provider of applications or devices that work with images is to ensure that the end result (in the case of 
Leica Biosystems Imaging, viewing an eSlide created by scanning a microscope slide) provides a true representation of the 
color of the original glass slide from which the eSlide was made.

Every image capturing device will transform the image color due to the particular characteristics of that device.

Fortunately, there is a way to take those characteristics into account to ensure that all along the path the image travels, 
from creation to display, color accuracy is maintained. As of Release 9, Leica Biosystems Imaging provides Integrated 
Color Management that works with the international-standard ICC color management specification to maintain image color 
accuracy.

ICC Profiles
The ICC (International Color Consortium) is a body that maintains a specification defining a color management system that 
ensures the color of images moved among applications, devices, and operating systems is maintained accurately.

The ICC defines a format for ICC Profiles, which describes the color attributes of a particular device.

Scanner ICC Profile

In order to describe the behavior of image capture devices such as an Aperio scanner, the devices must be calibrated to a 
standard color space, which creates an ICC profile. At the Leica Biosystems Imaging facility, an ICC profile is created for 
your scanner. The scanner’s ICC profile is called the source profile. This profile is stored as a standalone file in \ScanScope\
Profiles on the scanner workstation.

As you scan glass slides, the ICC profile for your scanner is also embedded in the resulting eSlide file. 

The embedded profile tells ICC-aware applications, such as ImageScope and WebViewer, the color-transformation 
completed by the scanner. This allows the Aperio Integrated Color Management to transform the eSlide to its original color. 

Display Monitor ICC Profile

The scanner’s ICC profile is not the only component of the integrated color management equation. The monitor you use to 
view the eSlide also has characteristics that affect color display. Your monitor may have shipped with drivers that contain an 
ICC profile for the monitor. Or, you can create a new monitor profile by using an external calibration tool. As the monitor is 
the final device in the image transformation chain, its profile is called the target profile.

http://en.wikipedia.org/wiki/ICC_Profile
http://en.wikipedia.org/wiki/Color_space
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If a monitor ICC profile exists, the Aperio ICC-aware applications will use it with the scanner’s ICC profile to display the 
eSlide color accurately.

How ImageScope Uses Color Management
ImageScope is an ICC-aware application, which means that for any eSlide containing an embedded ICC profile it uses the 
embedded scanner ICC profile and your monitor ICC profile to ensure eSlides are displayed with accurate color.

For information on how ImageScope uses color management with various ImageScope features, see:

`` “Viewing with Color Management” on page 29

`` “Chapter 13: Saving eSlides and Regions” on page 77

`` “Color Management Options” on page 132
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A
AFI (Aperio Fused Image)  41
algorithms  87

incremental processing  87
Algorithms window  91
algorithm tuning window  103
analysis. See image analysis
analysis results  58
annotations

adding text  64
Annotations window  62
changing color  63
drawing  55

arrow  56
ellipsis  55
free-form pen  56
negative pen tool  56
rectangle  55
report image  57

fixed aspect ratio  55
fixed size  55
grid, exporting  67
layers  58, 62

adding  65
attributes  68
creating  65
deleting  65
exporting  67
grid, exporting  67
hiding/showing  63
importing  67
visibility  63

linking  69
moving  66
panning while drawing  57
saving changes  67

viewing length and area  64
Annotations window  62

configuring  63
detailed view  58
plots  61
plots button  95
pre-processing  61
quick reference  62
summary view  58
transparent button  63

Aperio Integrated Color Management  136
arrow tool  56
autopanning  27
axes and grid  30

B
brightfield image adjustment. See image adjustments

C
cache

display  121
settings  123

changing color defaults  128
clinical viewing mode  23
closing eSlides  21
color adjustments. See image adjustments
color balance  38
color management  132, 136

ICC profiles  136
conferencing. See eSlide conferencing
connecting to scanner  114
CWS files  10

Index
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Index

D
deleting regions  61, 87
diagnostics  121
DSR  13

E
email settings  133
eSlide conferencing  106

changing leader  110
creating  108
joining  109
viewing slides  110

eSlide Manager report image  57
eSlides

closing  21
information about  19
opening local  16
opening recent  16
synchronizing navigation  25
viewing multiple  17
windows, managing  18

extracted regions  79
color management  82
fixed aspect ratio  83
options  80
predefined size  83
saving specific size  82
selecting  79
viewing applications  83

extraction tool  79

F
false color  40

applying temporary  40
features  9
file types supported  10
filmstrip  18, 28
fluorescence image  40

adjustments  46
adjustments, tips  46
AFI  41

adjusting  41
brightness, adjusting  46
channel

cycling display  44
registering  48
viewing information  44

color
adjusting  45
inverting  45

contrast, adjusting  46
creating RGB image  81
extracting  81
false color  40
fused image  41
fusing an image  49
gamma, adjusting  46
histogram

high clip  47
intensity thresholds  47
low clip  47
tone curve  47
transfer function  47

thumbnail, automatic contrast  46
viewing channel images  42

free-form negative pen tool  56
free-form pen tool  56
full screen viewing  25
fused image

adjusting. See  fluorescence image; See  fluorescence 
image

creating  49

G
Genie classifiers  100

H
histogram  47
HTTP proxy option  131

I
IHC analysis  58
image adjustments  36

fluorescence images  41
general tips  37
main image  36
Z-stacks  36

image analysis
classifiers  100
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Index

tracking  129
ImageServerURL  112
image settings

loading  39
saving  39

image view  10, 20
saving  20

Image view
opening  20

installing  13
integrated color management  29
Intended Use  9
interpolating  130
IQ   32

J
JPEG files  10

K
keyboard shortcuts  134

L
label rotation  35
linking annotations  69
Link Manager  69
links

creating  70
deleting  71
viewing  70

loading image adjustments  39
local image analysis  91
local image support  16
logging activities  121

M
macros  94
magnification  100

options  125
zoom slider  28

magnifier window  28
changing default resolution  28
magnification settings  125

exporting macros  94
exporting results  90
generate markup image  94
importing macros  94
local images  91
macros  97
markup image  94
modifying parameters  92
partial  86
registering macros  97
remote slides  88
result plots  61, 95, 93
results  95
running  94
selecting algorithm  92
selecting region of analysis  92
testing/creating macros  102

image information  19
image resolution  52

computing  53
setting/changing  53

image rotation  34
ImageScope

algorithm tuning window  105
disabling pre-processing  61
features  9
image view  10
installing  13
starting  13
toolbar, quick reference  23
window

adjusting  23
filmstrip  18
magnifier window  28
quick reference  22
status bar  20
thumbnail window  27

ImageScope options
analysis  127
annotation  128
default gamma files  126
general  125
HTTP proxy  131
integrated color management  132
magnification  125
navigation  127
performance  130
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Index

running image analysis  94

S
saving

image view  20
saving image to clipboard  77
scalebar  30
scrolling  27
security  14
SlideDat.ini files  10
slide-specific processing  58
smart synchronization  25
snapshots

creating  77
starting ImageScope  13
status bar  20
symbols  143
synchronization options  127
synchronizing navigation  25
system requirements  12

T
TelePath Live

calibration  112
connecting to scanner  114
ImageServerURL  112
live video  116
prerequisites  112

thumbnail window  27
TIFF files  10
toolbar quick reference  23
tracking  72

appending to a track  76
options  129
tips  73
viewing track  74, 75

U
updating analyses  61
user permissions  14
utilities  121

resizing  28
main image gamma settings  126
markup image  94, 127
moving annotations  66
MRXS files  10
multiple ImageScopes  122

N
navigating  26

options  127
panning  26
scrolling  27

NDPI files  10
negative pen tool  56

O
opening eSlides  16

P
page panning  27
panning  26

options  128
panning while annotating  57
pen tool  56
performance options  130
plots

enabling  93
viewing  95

prefetching images  121, 130
pre-processing  61
progressive rendering  130
pseudo-color. See  false color; See  false color

R
registering channels  48
registering macros on eSlide Manager  102
report image  57
image analysis  100
reverse panning  128
rotating

images and labels  34
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Index

V
viewing

full screen  25
live video  116
smart synchronization  25
track  75
with color management  29

viewing, full screen  25
VMS files  10
VMU files  10

W
Windows proxy server settings  131

X
X-coordinate navigation  27

Y
Y-coordinate navigation  27

Z
zoom, immediate

  29
zoom navigation  29
Z-stacks

calibrating  112
capturing  117
configuring  114
gamma settings  126
viewing  120
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Symbols
ÌÌ The following symbols may appear on your product label or in this user’s guide:

Manufacturer

Date of manufacture (year - month - day)

European Union Authorized Representative

In vitro diagnostic device

Serial number

Relative humidity range

Storage temperature range

Electronic and electrical equipment waste disposal

The exclamation point within an equilateral triangle is intended to alert you to the presence of important operating
and maintenance (servicing) instructions.
Le point d’exclamation dans un triangle équilatéral vise à avertir l’utilisateur qu’il s’agit d’instructions d’utilisation
et d’entretien importantes.

The lightning flash with arrowhead symbol within an equilateral triangle is intended to alert you to the presence of
uninsulated “dangerous voltage” within the product’s enclosure that may be of sufficient magnitude to constitute a
risk of electric shock to persons.
Le symbole de l’éclair avec la pointe de flèche dans un triangle équilatéral vise à avertir l’utilisateur que le boîtier
du produit présente une « tension dangereuse » non isolée d’une amplitude suffisante pour constituer un risque
d’électrocution.

The flat surface with waves symbol within an equilateral triangle is intended to alert you to the presence of hot
surfaces which could cause burn damage.
Le symbole d’une surface plane et de vagues dans un triangle équilatéral vise à avertir l’utilisateur de la présence
de surfaces chaudes qui peuvent causer des brûlures.

The UV lamp within an equilateral triangle is intended to alert you to the presence of UV light within the
product’s enclosure that may be of sufficient magnitude to constitute a risk to the operator.
La lampe UV dans un triangle équilatéral vise à avertir l’utilisateur de la présence de rayonnement
UV dans le boîtier du produit qui peut être d’une amplitude suffisante pour constituer un risque pour
l’utilisateur.
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