Table of Contents

Create Library ASSES WIth JUICEIS.........uuiiiiiie i i ee e s s st e e e e e s st e e e e e e s st e et e e e e s snnteaeeeaeeesaannstanneeeeesannnnnnnes 2
Convert Digital Juice Backgrounds to .MOV or WMV Files for use in Camtasia Studio 7 ...........ccccceeeviiiinnenn. 3
Access the Animated BaCKgrOUNGS. ..o ittt e e e e e s nbb e e e e e e e e e anas 5

Select the Animated Background to Convert to Camtasia Studio 7 Format.........ccccceevvvicciiieeee e ensciineenn. 7
Choose the Background’'s Camtasia Studio 7 SEtiNGS .......vvviirieeiiiiiiiiieee e e s e e e e 8

Import Background Video into Camtasia Studio’s LIDrary..........cc.ueeeeiioiiiiiiieiiieeee e 12
Convert Digital Juice Audio ASSEtS t0 WAV FIlES ... 13
Convert the Audio FileS 10 WAV FOIMMAL ........cociiiiiiiiiei et e e 15

Import Converted Audio Files into Camtasia Studio’s LiDrary.........ccccceeeiecviiieeee s e e 17



Convert Digital Juice Media Assets to Camtasia Studio 7 Format

Create Library Assets with Juicer3

¥ Camtasia Studio 7 only works with certain Digital Juice media files. This includes: Animated
backgrounds, stock images, music tracks, and sound effects.

V¥ Digital Juice media assets that contain alpha channel properties are not supported in Camtasia
Studio 7.

¥ To use Digital Juice’s animated Background media assets in Camtasia Studio 7, you must first convert them
using Digital Juice’s Juicer3.

Use Digital Juice’s Animated Backgrounds in Camtasia Studio 7
To use Digital Juice content in a Camtasia Studio 7 video project, you must:

Purchase media content from Digital Juice. Content comes on DVD disks.

Download and install Juicer3.

Load the media content into Juicer3.

Convert the Animated Background content with settings optimized for Camtasia Studio?.

Import the converted Animated Background media content into Camtasia Studio’s Clip Bin or Library.
Drag media to timeline to include in final video.

Produce video project as a shareable video file.

No o~ PRE

The scope of this documentation will cover steps 3 —5 above.

B For information on downloading and installing Juicer3, see the Digital Juice website.
B For information on creating a video project, working with the timeline, or producing to a shareable video, see

the Camtasia Studio online help within Camtasia Studio 7 .



http://www.digitaljuice.com/products/products.asp?pid=223�
http://www.digitaljuice.com/products/products.asp?pid=223�
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Convert Digital Juice Backgrounds to .MOV or WMV
Files for use in Camtasia Studio 7

To use Digital Juice animated background media files in Camtasia Studio 7, you must convert the files into .MOV
or WMV video files using the Juicer3.

Install the Digital Juice Media Previews in Juicer3

1. Start Juicer3.
2. Insert the content DVD into your PC’s DVD drive.
3. InJuicer3, choose File > Install Products.

=7 -
Juicer 3

Yijizards

Install Products...

b Mega Library 17
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4. The Install Products dialog box appears. The disc in the DVD drive will be loaded in the first field.

5. Inthe Change Location field, choose the folder that will hold this content.
6. Click Install.

Install k
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7. The License Agreement screen appears. Read the agreement then check the | Agree box.

Continue Cancel

8. Click Continue.

9. The install will begin immediately and progress bars appear.

Continue with Access the Animated Backgrounds.
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Access the Animated Backgrounds

1. When you first run the Juicer, the My Product panel lists the Digital Juice’s product categories that have
been installed. Click the arrows to expand the main categories.

HEE EAMEL [

EEE Animations

Click the
arrows to

expand the
categories.

2. Continue to drill down in the categories until you come to the installed products. The installed products
appear with a blue dot next to the title.

*Mega Library 13

PRO 104: Fibre Waves

3. Click on the desired project. The SD and HD options appear.

@ |f you will be converting an animated Background to Standard dimensions that use a 4:3 aspect ratio
such as 800x600 or 640x480, click the SD option.

@ If you will be converting an animated Background to Widescreen dimensions that use a 16:9 aspect ratio

such as 640x360 or 800x450, click the HD option.
4. Once the aspect ratio is selected, the specific media category folders appear in the Browser Panel.

 THE =

EEE Animations

*Mega Library 05

b PF 3: Target Blue
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5. Double-click the Backgrounds folder to open it. The media in that folder appears in the Browser Panel.

E’Eﬂ Anlmations

*Meqga Library 13

* PRO 104: Fibre Wawves

UEH Animations

*Moga Library 05

*Mega Library 13

6. Click on a Background thumbnail to preview the animation.
7. To move back to the folder view, click the Back button at the top of the screen.

Continue with Select the Animated Background to Convert to Camtasia Studio 7 Format.
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Select the Animated Background to Convert to Camtasia
Studio 7 Format

1. The Backgrounds that you want to convert to CS7 format must be added to the Batch Panel. You can add an
entire folder or individual files to the Batch Panel.

2. Grab afolder or file from the Browser Panel and drag it onto the Batch Panel.

Click and drag a folder or a

file from the Browser Panel
over to the Batch Panel.

Continue with Choose the Background’s Camtasia Studio 7 Settings.
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Choose the Background’s Camtasia Studio 7 Settings

1. InJuicer 3, choose Edit > Settings. The view changes from the Browser Panel to the Settings Panel.

~
Juicer 3

~ Canvas

~ Output

2. If the setting options are not open, click the arrows to expand each of the views. Your screen will look similar
to this:

A SETNINGS PANEL

~ Canvas
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3. In this panel, choose the following Settings.

Field ‘ Image ‘ Value

Canvas > Presets Custom

# If SD media was selected, enter 640 x 480
# |f HD media was selected, enter 800 x 450

Canvas > Canvas Size

Canvas > Pixel Aspect

Ratio 1.0 (Square)

Layer > Transformation Stretch to Fit

Output > Presets Custom

Output > Filed Order None (Progressive)

QuickTime Movie -OR- Windows Media

Output > Format . ' —= ' Note: Depending on the type of content you
are converting, one format might work better
than another.

If Windows Media is

selected, choose Output [+ VEBR. Quality - VBR Quality 80

> Format > format

Options button Check: VBR option

Choose: Quality option
Enter VBR Quality: 90

Format Options

Select the location for the content.

é’ Converted media that will be used in
your Camtasia Studio 7 projects should
be placed in a folder that will not be
moved.

This is because content added to the
Clip Bin or Library is referenced by
Output > Output Location default - not copied into the Clip Bin or
Library.

So, moving media content after it is used
in a Camtasia Studio 7 project will break
the project.

For more information, see Export the
Library as a Zip File (.LIBZIPﬁthe

Camtasia Studio 7 online help

4. Choose File > Save Settings. The Save Settings dialog box appears. Enter Camtasia Studio 7.
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5. To save these settings as your default settings, click Batch Panel Options at the tops of the screen. Choose
the desired default option.

» Canvas Save Settings :
A ' to Al

6. Click Save.
To convert all of the files in the Batch Panel at one time, click Render All.

Render 5

Render All |

N

To convert individual files, choose the files from the Batch Panel and click Render Selected.

-OR-

To select more than one file to conveh

1. Press and hold the <CTRL> key on
the keyboard.

2. Click the desired files in the Batch
Panel. When selected, they are
highlighted in blue.

3. Click the Render Selected button. /

8. The conversion process begins and progress bars appear.

10
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9. When the conversion is done, the Render Complete dialog box appears. Make sure the Show folder
containing the rendered output option is checked.

10. Click OK. The folder opens with the converted files.

l'\_.)'| . % Animated Backgrounds
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Continue with Import Background Video into Camtasia Studio’s Library.

11



Convert Digital Juice Media Assets to Camtasia Studio 7 Format

Import Background Video into Camtasia Studio’s Library

1.
2.
3.

Open Camtasia Studio 7.
Click the Library tab.

In the open folder media folder created by the Juicer, grab the video files, drag them over to the Library, and

drop them there.

E: Share
MName
|l 104_HD_Background2.wmv

[l 104_HD_Background3.wmv
|| 640x480 Overlay2.wmv

& Burn

Size
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Clip Bin

Edit
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Rounded Angles
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Sound Effects

Target Blue
TechSmith Samples

Import media

Title Clip
Folder
Folder
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Folder
Folder
Folder

& Produce and share ~ =

10 KB

Drag the converted
Juicer3 files into
the Library and
drop them there.

Image - ~ q
@ Audio2_2010-02-08_... Audic 4%@ v
] Image 433KE N
il HDRedeemerg40X480 Image 261 KB *
: Sequence_2010-02-... Sequence 601 KB
: Sequence_2010-02-.. Sequence 1195 KB
E Take2 Camtasia recordi... 34,012 KB B
B 104_HD_Overlayl 1 Video 157,535 KB
[ 104_5D_L owerthirdl Video 89,387 KB
Video 1,396 KB

WP 5404800 verlay?

To include the animated background in your video, drag it to the Timeline.

Camitasia Studio - Untitled.camproj
File y Too
" Record the screen ~ [KJ

m

«0)

You can also choose the Import Media button to add media to the Library or Clip Bin.
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Convert Digital Juice Audio Assets to .WAYV Files

To use Digital Juice StackTraxx audio files in Camtasia Studio 7, you must convert the .STX audio files into
WAV audio files using the Juicer3.

As with the other Digital Juice media files, you must first install the product into the Juicer.

v The StackTraxx series will come with an Index DVD and a set of audio CDs. To install the product into the
Juicer, you must use the DVD.

Install the Digital Juice Music Previews in Juicer3

1. Start Juicer3.
2. Insert the content DVD into your PC’s DVD drive.
3. InJuicer3, choose File > Install Products.

'.;::1 Juicer 3

Edit Eateh

Install Products...

» Mega Library 17

¥ Mena Librarv 18

Install

5. Inthe Change Location field, choose the folder that will hold this content.
6. Click Install.

13
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7. The License Agreement screen appears. Read the agreement then check the | Agree box.

Continue Cancel

8. Click Continue.

9. The install will begin immediately and progress bars appear.

Continue with Convert the Audio Files.
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Convert the Audio Files to WAV Format

1. Double-click an audio file to preview the sound.
2. Drag any file to be converted over to the Batch Panel.

Render Selected

Rander All

3. To convert all of the files in the Batch Panel at one time, click Render All.

Render Selected

Render All |
N

To convert individual files, choose the files from the Batch Panel and click Render Selected.
4. The conversion process begins and progress bars appear.

-OR-

Cancel

5. When the conversion is done, the Render Complete dialog box appears.
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6. Make sure the Show folder containing the rendered output option is checked.

7. Click OK. The folder opens with the converted files.

u'| . = Animated Backgrounds - | +4 | | Search o
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Continue with Import Converted Audio Files into Camtasia Studio’s Library.
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Import Converted Audio Files into Camtasia Studio’s
Library

1.
2.
3.

Open Camtasia Studio 7.

Click the Library tab.

In the open folder media folder created by the Juicer, grab the media files, drag them over to the Library, and
drop them there.

To include the audio file in your video, drag it to the Timeline.

You can also choose the Import Media button to add media to the Library or Clip Bin.
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